UI Path Orchestrator not working for community version

Hi I have downloaded the Community 2019.2 edition . I was struggling to configure the robot .
I navigated to Platform.uiPath.com
there I added a Machine template …I got a Key…
now I Ran the Ui Robot Service and pasted the key . I additionally added a floating development Robot with domain name and password from cmd -->WHOAMI
LAptop234/myname is the domain . I have clicked on connect in the UIRobot Service and the its getting connected , But the status in platfrom.uipath.com is disconnected for the created Floating Dev robot where I have given the domain name and password details.
I am using a ommunity version . when I have the UI robot opened and is connected to the machine template with the key I am unable to run any process form the STudio I get a error saying NO Robot is Defined in Orchestrator .
To resolve this I have tried to change the Domain name , but it didn’t work .
If I see my the properties of my computer (win10) where I nav to Change the settings oane there I see the Workgroup is checked but not the Domain.
The Workgroup is slected with the computer name and the domain name in the properties of this pc is not selected . IS this the same domain which deals with ROBOT ….what shall I change now. I have given the domain/username from cmd prompt by doing whoami…
my computer property is set to a workgoup …will this work >>>>>???
I want the Robot to connect.

Hi @SyedShabaz03,

Please try using the Standard Robot with Development Robot Type.

Thanks , I have tried both. I created a Machine Template first and the created a floating Robot with type Development where I have entered the Domain\Username and password from whoami CMD > when I opened the UIRobot and settings there I have pasted the machine key for the Machine Template I have , it shows as connected but there are no Robots Available .
2. I then Created a Standard Template and created a Standard Robot (Dev) and provided Username and password and then connect it t UI Robot via settings then also its connected but now it shows the status as Machine key has already been used by some other
3.Before configuring anything in Orch my studio was able to run the processes but now I see if I run the processes from the studio even manually or in debug mode also I get the same error that "Robot with username * is not available.

Your suggestions are most welcome and valued .


Also, In System Properties/Domain Change I see the computer name and member of WorkGroup there the Domain is uncecked has it got something to do with ?

Regarding the “Machine key has already been used by some other”, you can try create another machine which will generate New Machine Key. Use the new generated Machine Key at your UiPath Robot configuration.

You need to disconnect the UiPath Robot to run your other workflow at UiPath Studio (since the connected session between UiPath Robot and UiPath Orchestrator not able to connect to the proper Robot at the UiPath Orchestrator).

in UI path Robot Settings I had to enter Domain\Username and password
my domain&username is x\y I have entered it and provisioned the password . I am logged in as a Admin .
But when I see my system properties my system is in a Workgroup but not under Domain . Is this something which is causing error , Since my system is part of workgroup but not a domain ?

Also I further tried to add a domain to my PC which could be done in my win 10 edition. If this setting to Domain is needed then i will get it done if it is necessary .Can any one connect to the Orchestrator community Version using their PC which is part of a Workgroup.

Thanks for your Valuable inputs

i have the Domain\username from the whoami cmd

I tried as u said but unfortunately i am unable to connect

This is what i did for connecting UI Path Community Edition 2019.2 to orchestrator.
1.go to Platform.UiPath.com.
2.Create a Machine Template .Type Floating .Copy the Machine Key.
3.Create a Robot of type Floating (Dev or Attended) in my case Dev.
4. Provide the Domain\Username and password using the CMD whoami.
5.Open UI Robot Exe and settings paste the machine key and provide the Orchestrator Url.
6. The status shows as no robots available .
So please let me know if there is something wrong and how do I connect to the Ui Path Robot .


(2). Please try the “Standard Machine” (Provision Standard Machine)
(3). Use the “Standard Robot” and “Development Type”

Hi hermawan,
I have tried as u said with the standard template and Robot . But it does not work . Do you have any clue for the Robot setting Domain\Username . which I have entered as x\y from Cmd whoami.
the question is my Pc is a wind 10 Home pc part of a workgroup and not part of any domain .
then as per the robot settings Domain\Username
I don’t have a domain checked in my PC mine is a workgroup.
But though I assumed and tried it with laptop name\username
and cmd whoami as well

As suggested, use the Windows Command #whoami:

Copy the result from the #whoami command and use it as the “Domain\Username” at the Orchestrator\Robot Setting

What is the status of the UiRobot ?

1 Like

ROBOT unavailable , and the button above changes from connect to disconnect .
and when I see orchestrator robot status is disconnected .
When I RUn the process from studio it says Rabot with * username is not defined.

I am not able to post more than one image new user error

Hi @SyedShabaz03

Could you post a screenshot of:

  • Machines tab in Orchestrator
  • Robots tab in Orchestrator
  • License menu (top right) in Orchestrator