A robot with user name ' ' is not defined in Orchestrator

My processes start running with an error today, so thought to create a simple process to display a message and I end up in same error. Please refer below screenshot

I installed UIPath CE (community edition) studio on my personal laptop and try to run a process, it gives same error.
Is there any changes made to CE or there is any fix I can apply to sort issue.
Your response will be highly appreciated.

1 Like


From where you are running this process ?

Is your system connected to Orchestrator or not ? You have to specify the Domainname\username.

Open CMD prompt and then type whoami and it will give you both domainname and username and enter the same in Robot Provisioningin Orchestrator.

Thank you Lakshman for your reply.
My UIPath studio is connected to orchestrator through system tray.

I used to follow same approach till today and it used to work fine, but I am not sure what happened, as soon system gets connected to orchestrator, above error appears even running the process from studio.
This is my personal laptop and below is the name appears running WhoAmI command

I used the same name to create the robot but no luck

Below error while running the process from studio

I did lot of research but nothing concrete. I have wasted my one day because of this error, and I really can’t afford to devote more time on this.:;(

Can anyone suggest how to contact UIPath technical support plz

Your Robot name in Orchestrator is OrchestratorExercse, Please change the Machine* from PersonalLaptopStndMC to ‘kuku’ this is your laptop name and on Name* this is your Robot’s name



Worked like charm. I wasted my full day to figure out this minor error but you saved my night. I will certainly mention this in my blog so that others can find out this useful and save time.
Thank you mate.

Glad that we were able to help you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.