Running a robot unattended not working if screen locked

Robot running from unattended robot if RDP session is active but once it is locked or disconnected, it stops.

Please help.

Thank you.

This means, the unattended robot, behaving as attended/development robot. The robot settings will be the key here. Make sure you have Login to console is selected with No and resolution settings is on and values for Width and height are given with Development machine display settings.
image

2 Likes

Sorry i missed the screen shot

3 Likes

Thank you for the reply. I will try this.

1 Like

If it works, please mark it as solution.

It did not. Please advise further :slight_smile:

Please provide more details about your setup. These symptoms can be caused by your UiRobot configuration, Machine/host configuration, or how the process is designed.

Are you starting a job with an unattended robot in a truely unattended mode or do you have it connecting to an active user session on your local or remote host?

If you are connecting to an existing session you must keep it logged in and unlocked otherwise it will interfere with the execution. This applies if you are RDPing into the remote host on the same session including minimizing the RDP session window.

If you are connecting to a remote session with an active job and want to disconnect without waiting for the job to complete, you should be able to redirect the session back to the local console using the tscon command.

Is your UiRobot registed as a service or is it installed in user mode?

There are a few other reasons I can think of, but it would be easier to diagnose if we are provided with more information.

It turns out the licence type was “studio” and not unattended :slight_smile:

I have the same issue could you solve it?

I am also facing same issue

What you can try:

  1. As @Ramki81 said adjust your robot setting to the screenshot he provided

  2. Check if the robot server/PC/RDPsession/VDI has the robot service running.
    image
    You can also check this in the approriate Tenant —> Folder —> Robots where all connected instances will be green.

In addition to the above, if you are using Modern Folders remember that the user (robot user) needs to provide correct credentials to login to a remote server/PC/RDPsession/VDI:
3. Check if your unattended bot user has been allocated the correct domain\username and password in the Edit User window

Hi all,

I’m facing a similar issue.

Process not getting executed as needed when I trigger the process through schedule without accessing the RDT MC.

I have developed a workflow that runs fine when I run it through studio as well as Uipath assistant. It also works when I run it through the Job session in orchestrator.

When I schedule the bot to run at a particular time while I have access to the machine it works as expected.

But when I schedule it at any time while I don’t access the machine it fails. After 3 mints of execution is throws activity time out error.

Can any one tell why this happens? also I’m getting an email error summery saying Robot is unresponsive. (#1223). ? while I disconnect from the MC.

But when I access the MC the robot gets automatically connected and job runs.

Thank u.