Run script using cmd. Error on Database activity and Excel

“C:\Program Files (x86)\UiPath\Studio\UiRobot.exe” -file:""

I want to run the UiPath script through command prompt.Its working fine using above commands. But when I used database activities (as well as excel activities) and connection in uipath workflow its showing error.I am using Uipath studio 2018.2.3
Can you please help.

Hi
Welcome back to uipath community
May i know what was the error
if possible can we have a screenshot of it
that could help us go in right direction
Cheers @avldev

Hi,
I run the .xaml through cmd, it is working fine but when the part of connecting to database and returns datatable, it is not executing. I put message box before the connection to database and after. The message before the database activity prompted, but the after is not prompting. My conclusion is that there’s an issue. I tried to execute it using the uipath studio, it runs perfectly without error. @Palaniyappan

Fine
Try with this command, Open your Command Prompt ,
It Will Open By the Default Location "C:\Users\username"
enter this

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe”

then Enter the Below code

/file:“C:\Users\yourusername\Documents\UiPath\RPA challenge\msg.xaml”
(that is the file path of the xaml)

hope this would help you
Cheers @avldev

@Palaniyappan, i used that

It is still not executing the database activity and excel. is there be an access issue on database that’s why it is not working fine when i run it using cmd?

@knight.star, hi, what do you mean it can’t? Thanks.

Fine
first we need to execute the database exe
may i know which database is used mysql or oracle
then only we need to execute the above two commands
Cheers @avldev

@Palaniyappan i am using oracle, how do we do that?

Hi to all having the same issue. I resolved the issue by publishing first the project. Then try to run the project again using the .bat and it should be working fine. :slight_smile: