Trying to get batch program to run uipath xaml

I am trying to get a batch program to run the uirobot.exe and then run the xaml file listed after it. However all that is happening is the batch file is running and then closing. It doesn’t appear as if the xaml file is even running, because other wise, i would get a messagebox to pop up sayng hello.

Could you help me figure out hte issue. Here is my batch file

Batch file content
“C:\Users\dpsmith\AppData\Local\Programs\UiPath\Studio\UiRobot.exe” execute --file “C:\Users\dsmith\Documents\UiPath\GetOutlookEmail\Main.xaml”

1 Like

Hi @daryl_pressley

Please check this

I hope this is what you are looking for



Is your project Windows-Legacy or Windows?
If Windows project, can you try to use --file option with nupkg file or --process option because Windows project Is not supported to launch from xaml file.
Please see the following document in details.


I have tried the options you listed and I am still not getting it to work.

One of the options was to try and run it using an nupkg file, but the project is not creating any nupkg files.

I tried the following and got this erro message

C:\Users\dp\AppData\Local\Programs\UiPath\Studio>UiRobot.exe execute --file “C:\Users\dp\Documents\UiPath\Display Message\Main.xaml”
You can only run .NET6 .nupkg files or published process from the UiRobot command line.

I figured it out.

“C:\Users\dp\AppData\Local\Programs\UiPath\Studio\UiRobot.exe” execute --file “C:\published\Display.Message.1.0.2.nupkg”

I published the package to another folder, and found the nupkg file, the above allowed it to work. Thanks eveyrone

Marking as fixed

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.