Error in starting UiPath .xaml file from command line

i am getting the below error while invoking UIRobot.exe from command prompt.

Invalid command line: “C:\Program Files (x86)\UiPath Studio\UiRobot.exe” /file:“the filepath”

The command i am using is:

“C:\Program Files (x86)\UiPath Platform\UiRobot.exe” /file:“the file path”

I have figured out where the issue is.
Its with UiRobot.exe.
Whenever i try to run it with cmd. It gives me “Invalid command line” error.
But the UiRobot does start after I execute the command.
I have restarted the robot. Stopped and again started it, but I am facing the same issue.
I tried it on another PC, there this piece of code worked fine.
What could be the issue?

Hi Aditya,

Please try this way. When you first open the Command prompt:

  • cd C:\Program Files (x86)\UiPath Platform
  • UiRobot.exe -file “%HOMEPATH%\Documents\UiPath\test_debugging\Main.xaml”

Let me know if it works. Thanks!

Here is the list of command line arguments:

1 Like

Hi @ovi,
I tried the command you suggested. It didn’t work and I am facing the same ‘Invalid Command Line’ error.
I tried this command on the other PC in which there was no problem and it worked.
Could it be issue with admin rights?
Or wrong installation of the UiPath Software. because UiRobot starts perfectly fine and it was running when i was running my xaml through studio but its not running through cmd.

Can you start the cmd line as admin and try again?

Hi I am using the above command, but it gives me below error:

The message with Action ‘http://tempuri.org/IUiPathRemoteContract/IsAlive’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

Hi @Gabriel_Tatu,

I want to run the UiPath script through command prompt.Its working fine. But when I used database activities (as well as excel activities) and connection in uipath workflow its showing error.I am using Uipath studio 2018.2.3
Can you please help.