RPA on Delphi 7

Hi Community,

I’m trying to automate a task in Delphi 7 using Uipath. But Uipath does not recognize Delphi 7. I click on the program and the parameters look empty as if I had not clicked anything. I tried using Data Scraping, but it does not work, nor does it recognize it.

Does not recognize buttons or msg boxes, just that they are windows.

I’m still learning to use RPA, so I do not have much experience.
Can someone help me?

Thank you

Hi Pedro,

Have you tried with image automation? (click image activity for example) I will double check with product and dev team about the Delphi 7 automations.

Yes, I tried.
Unfortunately it seems that it does not recognize the graphical interface of delphi 7. I believe the program does not see it as an application.

Hello Viorela,

Thanks for your help.
I have partially discovered what the problem is with another application.
I used a mouse recorder to try to automate what I need and I discovered that it also did not recognize the Delphi 7 interface.

I decided to install Uipath on another machine from a colleague who already used the mouse recorder and guess what … it worked!

Conclusion, the problem was not Uipath, but something in the Delphi 7 graphical interface of my computer. Who knows, some application was missing, I’m still investigating.

Anyway, thank you.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.