UiPath unable to work with legacy system

uiautomation

#1

Hi all,

I have started exploring UiPath as an RPA tool to automated some tasks on our legacy ERP tool (Sage EasyPay)

Unfortunately, despite the hype over RPA, I can’t seemed to get UiPath to work with my legacy desktop application.
E.g. When I am using the recording tool, it is unable to identify the elements on the UI or does not register it as an action.
(And yes, I’ve tried with newer applications and websites and it works fine, just not on my systems)

Is it possible to record based on mouse coordinates instead of elements? Or this is the limitation of RPA tools where it may not necessarily work with all applications ? (Which wasn’t a topic that was widely discussed surprisingly…)

Thank you.


#2

Have you attempted to use the Click Image or Click text capabilities?

You’ll find them in the desktop recorder; Image -> Mouse -> Click.

Alternatively, I’m pretty sure you can use the citrix recorder for easier access.


#3

Hi,

Thanks for the suggestion.

Tried both, however, it doesnt work (it just pushes me back to the UiPath toolbar without any action record)
Guess it doesnt work very well with legacy systems ^^ "