RPA Advanced Learning - Assignment 2 evaluation issue


I have submitted my assignment 2 solution for evaluation and every time I get same result Failed: 0/100 and the automated response from the evaluator, Total Items: 10, Completed items:10 Correct items:0
I have validated that each item

  • Status is Completed
  • Filename that was uploaded = “Yearly-Report-2017-[TaxID].xlsx” (Exact filename)
  • Yearly report contains all available monthly report information (merged file)
  • comment contains the correct Upload ID

What else should I do? Can anyone please help?
I have already submitted my assignment 3 times


Hi @rajbhattac,

Did you reseted your data from acme after submitting your assignment???

@ovi will guide you


Hey did you put "Uploaded with ID [uploadID] "as a comment in the add comments field.

No I did not reset the data.

Here is the screenshot of one of the work item

I submitted my assignment for the 4th time today and again the same result Failed 0/100

Can someone please guide?


I re-submitted my assignment for the 6th and the same result Failed:0/100

This is frustrating. I dropped a message to @ovi regarding my issue but no response. Is there anyone who can help or guide me to resolve this?


1 Like

Did you reset your data before running the workflow? Because you orchestrator must have fresh items to work on.

Try this

  1. Reset your data
  2. Clear your queue
  3. Run dispatcher
  4. Run performer
  5. Submit your assignment

If this does not work see if you can find something in output pane after running your workflow in case you find an exception


I would say check the spacing in your filename and the hashID you extracted from the upload submit dialogue box

Make sure the comment is “Uploaded with ID 87984798324hjjhjh”

(exactly like that without quotes and no extra space after the hashID itself)

Also check if the excel you saved was actually .xlsx and not a renaming from .csv to .xlsx

1 Like


Thank you for responding.

I have confirmed that the comment is as per what you mentioned above:

Here is the snapshot of the completed work item

Extracted the comment for you to review: Uploaded with ID 1ed161eec346d01f786602a5796369e7

I have uploaded the video if my assignment. Can you please review? Here is the link - - YouTube

Also all the Yearly report files that I uploaded are in “.xlsx” format

Let me know in-case you notice any issue in the solution


The process seems good, so the problem may lie in the excel file itself (the merging) can you please upload a couple of report (.csv) and a merged final yearly report (xlsx)?

The merged file data is also a criteria in evaluation so maybe thats where it is failing

I have attached the individual monthly (.csv) file and the merged yearly report for WI - DE325476
WI-DE325476.zip (8.4 KB)

Where is the header in yearly report? :slight_smile:

Try adding that , when you are merging. Then try the evaluation again!

Goodluck :slight_smile:

Thank you for pointing that out. Let me try with the header.


I re-submitted my assignment and made sure header is included in the yearly report but still the same result, Failed: 0/100

Here is the link to the new video: - YouTube

Monthly and yearly report generated for WI-DE325476
WI-DE325476.zip (8.4 KB)

How are you getting the Data (WIID) to process. Didn’t see a step regarding their processing (like using screen scrapping or something else)

I run the dispatcher workflow first to load the queue with the data by scraping ( navigate to each work item page and extract data from the table) and then I run the performer workflow to process each data from the queue.

The Sequence of Columns is different. Date needs to be at the end. Compare the yearly report with the Monthly file (column Sequence)

I just downloaded the monthly report for one of the Work item and this is the sequence that i see:

InvoiceNumber Item Amount Tax Total Currency Date

And here is the sequence of columns in my yearly report:

InvoiceNumber Item Amount Tax Total Currency Date

They are the same

@neonova - One thing i noticed is that the date format in the monthly report is “1/18/2017” but date format in my yearly report is “2017-01-18”. could that be the reason?