RPA Academy - Leve 3 advanced training assignment error

Hello,

I’am currently doing a RPA Developer set of courses and everything went like a charm. But I encountered an issue in 1st assignement in Level 3 advanced training.

I’m getting this error:

{
“message”: “System error at initialization: The values provided for the root activity’s arguments did not satisfy the root activity’s requirements:\r\n’InitAllApplications’: The following keys from the input dictionary do not map to arguments and must be removed: in_ConfigFile, in_ConfigSheets. Please note that argument names are case sensitive.\r\nParameter name: rootArgumentValues at Source: System.Activities”,
“level”: “Fatal”,
“logType”: “User”,
“timeStamp”: “13:45:19”,
“processVersion”: “1.0.0”,
“jobId”: “9a970ae3-3434-4366-beb3-eb4bd98150c8”,
“robotName”: “orchestrator_demo”,
“machineId”: 182037,
“fileName”: “Main”
}

I have tried debugging, checked arguments and invoked arguments, and everything seems OK, yet I’m getting this error message.

Any advices?

Welcome to uipath community
–it seems like the argument passed though correctly, we need to check whether that is passed to right argument and we need to check the dictionary variable and the way its key is used (we need to check with whether right key is used or not)
–then make sure that the variables and arguments are meant exactly as same as they are defined…even the case sensitive and check it scope, mostly the variables should be of global, that is the scope should be of whole sequence

hope this wuld help you
Cheers @Kozak

1 Like

Thank you for fast answer.

I have solved this issue, 5 minutes after posting this after long time of debugging.

I missed one little invoke, which caused this error.

Great
Cheers @Kozak

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.