Robot stop working on a VM when user session is locked

Hello guys,

I have a problem with running my robot on a VM even if the user session is locked.
Here’s some details :
I run the VM from a laptop. Then, I run the attended robot on a VM.
When the user session on my laptop is locked, the robot running on the VM stops working.

I used Launch workflow interactive, but, it doesn’t work either. I discovered that this activity is obsolete since UiPath v2018.2.
Currently, I am working on UiPath v2018.4.1.

Can you help me guys on this topic ?

Thanks in advance.


Are you using community edition or enterprise edition of Orchestrator ?

Currently, I am not using Orchestrator.


Ok. Attended BOT won’t work when the user session is locked and it is the functionality of attended BOT. Make sure user session won’t lock.

I also faced this issue. So, I am running one VB script file to make session didn’t get lock. Now, issue resolved.

@lakshman : Can you please send me the VB script file that you run. If it is not too much to ask ?


Please find the attached file. After logging into system just run this file then system won’t go to sleep and lock. (213 Bytes)

Thank you very much !
But, to clarify things, do I run this script on the VM or on my local computer ?
I am sorry for this question but I have to be sure.


You have to run it in on local computer.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.