Robot stays in running state even when all the activities are completed when running from orchestrator or robot tray

Hi,

The Uipath process running from orchestrator or robot assistant gets triggered and all the activities are getting completed but the robot stays in running state without getting stopped or killed. How can we resolve this.

Additional Info: I noticed something weird. The process ran successfully from orchestratot and then again starting runnnig. How is this possible? :slight_smile:

Could you please help me why this is happening @loginerror.

Thanks

@ashishsinha1504 Have you set any of the Trigger for the Process?

Any more details about your process would also be appreciated :slight_smile:

yes @supermanPunch. I have set triggers to run the process. So the robot is unattended and even after the successful run goes back to running set which is very weird. Also i have set the kill triggers after 3 minutes of run which doesnot work as the process first is successful.

Hi @loginerror.

Sorry about that. So my process call a batch script that encrypts my text file and sends mail using outlook that the process is completed. When i run it from studio works fine but shows issue when using triggers.

Thanks

@ashishsinha1504 Is it a time Trigger Or a Queue Trigger?

Time trigger

@ashishsinha1504 Can you provide the Time Interval that you have set, and if you could provide the Screenshot of the Time Trigger Configured in the Orchestrator, it would be very helpful to solve the issue.

So this time is actually PST timings

For more info.

@ashishsinha1504 Yes. I have tried the same configurations with a Message Box Process, It had executed properly actually, there was no Re - Execution occuring. Not sure why you have run to this problem. Anything useful in the Logs?

No nothing as such in logs. Its just that the robot is behaving weirdly but the process works fine. I get the mail of success execution as well. The bot stucks in running state thus affecting other processes that runs after that.

Hi @ashishsinha1504

Could you navigate to the Job logs of the stuck process and show a screenshot of that?

Global-logs.xlsx (11.5 KB)
PFA the logs. I have set the logs in verbose.

If the issue is still happening, would you mind showing the screenshot from the Jobs page? Does it display your first process as Successful and then another one, a new one, as running indefinitely?

What do the logs show for the other Job if that is the case?

Its not happening right now but this has happened before as well. So the bot runs at some time which i cant monitor. When i triggered the job from orchestrator manually i saw it getting succeeded and then going back to running state. If you see the logs that I attached above, the execution is successful but the process runs indefinitely.

I’m having the same problem. Seems like it something from windows that is preventing right communications.

I’ve changed the robot to 3 different computers, and inside UiPath assistant it won’t finish the process and no error is thrown. Studio runs normally, even when assistant do not process the entire flow (there is a condition to start or not at the beggining), it can finish.

Having this problem for several weeks and seem to be randomly: sometimes it finishes, sometimes not.