Robot is getting stuck in Running State

The robot in the orchestrator is getting stuck in Running State (not at a particular point) for hours. It is not throwing any exceptions. I don’t find any logic behind it. We have gone through windows event viewer logs and didn’t find anything specific to it.

Is anyone facing the same issue? What would be the resolution?

Hey @santhoshreddy,

Are you using RE:Framework ?

If yes then this issue is caused by null trigger execution.Please do a check between state transitions if there is any null trigger execution in place.

I ran into the same issue but when i debugged the code thoroughly i figured out that null trigger keeps on running due to which my code is running forever.

There has been issues like this related to servers. The instances I have seen this were either due to the user profile for the Robot was corrupted and could not create a login session (this usually means the process never started at all), or there is a Windows popup/crash message on the session that did not allow the Robot to throw an exception on in which you would need to identify the source of the error and suppress it, typically.

So, I think you need to figure out at what point does it get stuck through monitoring its logs (also logging into the server when it is stuck can tell what it is doing also). One issue with troubleshooting this too is that if the login session does not exist, the robot creates it then logs off when it is complete, so you can’t see what happened when you Kill the process to stop it. But, if you log in to create the session on that robot, then it won’t log off after it is complete (from my understanding) - this is assuming you have access to the robot user profile to login with.

It’s kind of tricky solving server issues.

Also rule out infinite loops in your code, like if you have any Do while that need an exit routine.

Regards.

1 Like

Hi @santhoshreddy,

May I know the input for this bot?

Hi @amarasto. Yes, I am using RE Framework. There is no null trigger execution between the state transitions of my script.

Hi @Karun. The input is an excel file.

Hi @santhoshreddy

I am facing the same issue when I run my project in debug mode
it is running forever without any exceptions and outputs. I am guessing because for my project
input is a text file of around 3 lac records and my functionality is to loop all these records that’s
why it stuck in somewhere.

May be in your case also excel file has huge records

Hi,

I facing the same issue. Job is getting stuck in running state in the orchestrator. I have checked the logs, there are no null triggers.
When i run from studio it is running perfectly fine.

Anyone solved this issue?

Regards,
Srujitha

@ClaytonM @amarasto @Karun @Srujitha Thanks for your response guys. The issue has been resolved. The excel has a lot of records. We replaced all the excel activities with the workbook activities. It is running fine. Looks like excel activities have some issues.

I to have a similar problem to the one described here, except that my process does only occasionally get stuck in Runnig State… So far I have been unable to find a pattern as to why this is occuring, but I have added lots of log-statements to my process in the hope of pinpointing the location where it hangs.

What my process does is the following:

  1. Periodically checking a folder for new Excel-files containing some products.
  2. If files are found, do some validation on the files in question
  3. If validation is ok, write the path of the files to an Orchestrator-queue for further processing.

The validation step (2) consists of opening a huge Excel-spreadsheeet with all products (60k rows) checking each product in the files from 1 against the product “database”.

I am using the Close Workbook activity for each Excel-file I’m opening.

Even I am facing this issye of Robot getting stuck during execution from the past 6 months and UiPath has not provided any solutions/fix to it.

Hi @ripers @MariaJosephina,

The robot gets stuck when any other process is running simultaneously. For example, if you are opening excel, the system will check the license of the excel, this check may take little time or long time. If it takes long time then, when the robot tries go to the next step, it gets stuck as the system is still checking the license. In my process, i was adding data to excel, so by unchecking the visible property, i have solved this issue.

Hope this helps you.

Thanks,
Srujitha

@Srujitha

Uipath support team confirmed that “it is a bug with UiPath robot”

2 Likes

Thank you for update @MariaJosephina. Just of curiosity: do you have a link to the bug-issue in some issue tracker?

1 Like

Hi Maria

Can you please share the details around the confirmation from UiPath that its a bug.Please share the blog/email or scenario where they said its a bug.

Which version of UIpath its a bug and Has it been solved in later versions.

Also, this is my Whatsapp group “RPA Worldwide” with RPA experts from various countries. It would be great if you can join and share your answers on this group.

Uipath has not given any timeline or links on the same for us to track.
They are not sure on when this will be fixed.

If I am also strucked with the things in top schedule button I click its not clicking that button and then it’s strucked it 2 hours more I don’t know why??? What can do now i am not using reframework

This issue used to happen to me as well.

I solved it by removing the Excel Application Scope activity that was causing the problem. The UiPath Support team told me that, when using such activity, UiPath makes a check to the Office license. If there is some kind of problem with this check, the activity gets stucked somehow and provokes the issue.

I used “Read Range Workbook” and “Write Range Workbook” activities instead and made sure that any hyperlink was present within the Excel file. These activities do not need of an Office License to work.

Also, could be solved by upgrading UiPath to the version 2020.4.1

Best regards,
Marina B.

Hi @Marina_Ballester,

“Also, could be solved by upgrading UiPath to the version 2020.4.1”. How do you know this can be solved using 2020.4.1? Is there any official changelog that telling this issue has been fixed? In my case, i couldn’t remove the excel application scope.

Thanks,
Alex