Orchestrator Process Successful, but nothing happens

I have a following setup of 3 virtual PC:s

  1. PC1 is where UiPath robot is running
  2. PC2 is used for Studio
  3. PC3 is used for Orchestrator

I have connected both PC1 and PC2 with PC3 in Orchestrator.

I scheduled a process with Triggers. when it is completed, Orchestrator says that the status is Successful, but when I look at the duration, it is only about 30 seconds (in reality this process would take 2-5 minutes commonly). The robot also should have sent some e-mails within the process, but it seems like that nothing has actually happened. Only log events I can see is that the process has been started and then stopped.

What could be reason for this?

I have run the process several times with Studio in PC2, and everything works. I also tried to run the process manually from Orchestrator, but it either does the same thing as I explained first, or then it crashes, because some selector cannot be found. NOTE: The second scenario happens only, if I open a remote desktop connection to PC1 at the same time, when the process is running.

I have also tried to run it from PC1’s UiPath Robot-prompt and everything works.

Hi
Welcome to uipath community
We can check that with logs
May I know what level is log is set with in the machine where this process is ran
And also check whether the username and domain mentioned is correct or not while creating robot
That is go to your machine cmd window where we are going to execute this process and type the command as whoami so that it will give us the username and domain and also mention the password correctly, mostly it would be correct else would have got some other issue
But let’s confirm once and also set the robot type to UNATTENDED or Development while creating h the robot in orchestrator

Cheers @alerpa

Hi, the Robot logging level in PC1 is Information.

So is this correct:
In UiPath Robot settings in PC1: Machine name is the name of PC1, OR should it be the name of the Orchestrator PC?

The robot is unattended. @Palaniyappan

Fine
If possible can I have that screenshot of robot tray and also your orchestrator robot tab
Cheers @alerpa

And here’s Orchestrator:

Here’s Robot: rob1

Hi, is it your project has more than one XAML files? If yes, can you please check the XAML you want to execute has set as main or not. Thanks.

I have named it as Main.xaml, is there anything else that needs to be done?

Hi, I guess UiPath doesn’t have any fixed main entrance. But you need to right-click the file you want to let it becomes “Main” and “Set as Main”.Capture

I set it as Main, but no help. Still if I run it directly from Robot-PC, it works, but if I run it from Orchestrator, it doesn’t work. It seems that there is something wrong with UiPath recognizing selectors. It looks like that when I cannot see the robot doing the process, it doesn’t do it correctly, but when I have connection to the robot-PC and run it, everything works. What can cause this? It is a process made in Microsoft Dynamics AX 2012.

I went from Orchestrator --> Robots --> edit --> Settings --> And set Resolution to 1920x1080x32 and Login To Console No and now everything works.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.