Robot not visible in 'start job'

This is my Orchestrator:
image
This is my Robot:
image
My Environment:
image


In “start job” I can’t see my robot
image
I tried to change my robot from type “Studio” to type “Unattended” in this way I can see the robot:
image
But when I press “Start” button the state is “Faulted”
image
What am I doing wrong?

Check on the below steps

How to deplay and trigger a process

Step1: Go to studio and publish the project as a package.

Step 2 : In the browser type “ui path orchestrator login” and login with google account. And then Go to the instance and click to open the Orchestrator.

In My Case

Step 3: To Run the robot in Orchestrator you first need to create the robot.

CLick on the + button and enter the details

Note: Domain name should be same as computer name / CMD → Whoami

Step 3: Go to environment and create environment.

Step 4: Go to process tab and add a process.

→ Select the deployed package.

→ Select the created environment

Step 5: Configure the Ui Robot

→ Add the orchestrator URL

→ Add the machine key ( you will find it from machine tab )

Step 6: Go to Jobs and click on play button

→ Select the process

→ select the robot and click on start.

—> How to Start, stop and kll jobs

→ How to configure schedules.

→ How to view and modify log message also manage alerts.

→ Asserts → 4 types → text, boolean, integer , credentials.

→ Inputs can be provided in 3 ways

  1. Studio → Manually but the package should be updated before execution.

  2. Orchestrator → By providing arguments or by editing the value of an asset.

Providing a text value in orchestrator asset page to be written in the notepad.

This will get the value of the asset and type in the notepad.

Providing value per robot

→ Each robot wil type differently depending upon the value provided.

You can also pass the Username and password

→ In the asset page choose value type = credentials

Queues in Orchestrator

→ Read excel file and values to the queue

→ Create a queue in the Queue tab of orchestrator

→ 2 process one for adding list items to Queue and other to process it.

→ 1st process to adding items into Queue ( as shown in the screenshot)

→ 2nd process to process the Queue items

1 Like

I’m building my first automation following step by step how explained in the lesson. In screens that I have attached, I followed the same steps you showed but when I choose “JOBS” and I wrote the environment my robot is not listed. Then I can’t choose and “start” my job. Did you find any mistake in my attached screens?
If I change my robot in “unattended” instead of “studio” I can see my robot in “JOBS” , I can choose it and “START” but after that it does’t work.
Many thanks for your support

@MariaClaudia - - Please follow below steps
1- Go back to Robots page and update your robot password as robot user in password textbox/field(keep the type as unattended) -click on - update…
2- Go to Platform.uipath.com --> Services and verify Unattended robot allocation - pls refer below link for https://docs.uipath.com/cloudplatform/docs/distributing-your-licenses
3- Go back to Start Job window and verify - robot will be available for allocation.

I saw the example:
image
But in my screen I don’t have button “Request More Licenses”:
image
Am I in a wrong place?

Hi @MariaClaudia

This is correct. From 20.4, the Studio type robot no longer allows you to launch processes from Orchestrator. This was a design decision.

It should allow you to schedule a process when your robot is set as Unattended though (or Non-Production, but I don’t believe there is a non-production robot for Community licenses).

@badita?

Hi,
So there is no way to complete my first automation?
Anyway, thank you for your helpful.

Hey MariaClaudia,

You can still run your first automation , you just have to change the robot type to UNATTENDED from STUDIO.

Please let me know if that works.

1 Like

Hi,
I already tried to change my robot from type “Studio” to type “Unattended” in this way I can see the robot:
image
But when I press “Start” button the state is “Faulted”:
image

With “Studio” instead “Unattended” I can’t see the Robot.

That’s a good progress Maria , You are able to run the job ,now let’s troubleshoot as to why its failing.
Can you please click on the bell (Alerts) icon on the top right of your screen and see the detailed error as to why it failed.
After clicking on the Alert icon, you have to again click on the “i” icon , to see the detailed error.

If you could paste the error here from there,I could help you much better.

1 Like

Hi,


image
Is it right?
Many thanks for your helpful.

1 Like

Yes @MariaClaudia, That really helps!

Your system password is incorrect in your Robot settings , please go to Robot and click EDIT and update the password(enter your system password here) by removing everything(default password) which is present in the password field, That would make it work for sure.Happy Automating !

3 Likes

GREAT! Now it works! Thanks again

2 Likes

Hi,
Yesterday I was late, I saw that the message “helloWorld” did not appear, but I thought to have forgot some step. The state of job was “Successful” so I though that was ok.
image
Today I tried again, in the state of job appears successful but the “HelloWord” message did not appear.


In UiPath Studio I saw this message:
image
Could you help me please?

The message has nothing to do with the issue. Can you try again?

1 Like

@MariaClaudia, what message appeared today , instead of “Hello World” , can you try re-running the job once again ?
Can you re start your system today and retry the same ?
Message seen on UiPath Studio is legitimate and can be ignored.That is not a problem.

1 Like

I tried yesterday, this morning I restarted the system and when I execute the job, I think to see the message “HelloWorld” but nothing appears.
image

what happens when you run the xaml file locally / directly from UI path ?

@MariaClaudia, please create a separate post ,as for this topic “Robot not visibile in ‘start job’” original problem is fixed and

Robot is now visible :slight_smile:

1 Like

You are right. Now I check if there are already a similar case, otherwise I create it. Many thanks

1 Like