Robot isn't running as I scheduled on Orchestrator- Community Edition

Hi everyone,

I have scheduled a job to run every minute. But it’s not working.

You can see the process that i try to running as below .

Also on yesterday, when i tried to execute at 2:00 pm it wasn’t executed. But after 5-6 hours later it has worked.

In that topic the problem seems similar as i realized.

So what am i doing wrong, could you help me please?


Hi @alpersahin

Most likely some performance issues, my bet is that our team is already looking into it :slight_smile:


Thank you for quick response!

So will we wait too much until it will be solved ? Or how can i learn when it’s figured out? :slight_smile:

I can’t provide the exact time, but historically those issues are resolved in a timely manner.

Please periodically check if it got better and keep reporting back in case it doesn’t :slight_smile:


hi @loginerror

May i know any update with Orchestrator CE ? My schedules are not accurate as well. Running whatever they want not based on the schedules.

1 Like

As of 14th of March, schedules are still not working. @loginerror
Just updating you and everyone who is running into same issue.

1 Like

still schedules are not working.

Hi @hangon

Thanks for keeping the reports coming. This particular issue is currently being investigated.

Orchestrator is still not working… Jobs are not being executed on schedule. Please fix this! It has already been several days. Could we get an estimate on about how much time it will take to fix this recurring problem?


Hi @loginerror , even i am facing the issue . Can you please give an ETA of this issue.


For everyone,

Schedules are working now. Thanks UiPath team.

1 Like

Scheduler is running but actual process is not started. When i go in view jobs, its empty.

Hi All - I had same issue yesterday. I gave up, disabled the schedule and logged off my machine. When I logged on again today and logged back into Orchestrator and enabled the schedule it started working fine. Every minute as per schedule the message box appeared. See attached image of the schedule. I did nothing different except the shutting down of my lap top, powering back up and logging back into Orchestrator and enabling the schedule again. I am using community version and doing the Level 2 Orchestrator course.

Hi @ColinCrabtree,

I had same too. After I published a process and add on schedules, it was not started. When i restart my machine than it works properly. I can not recognize that we always have to do like this or not.

Hi @loginerror :slight_smile: ,

Could you help us about how system works ? Should we always restart machine or server to activate scheduler when we add a new process on it?


I am not sure. I am a rookie still and have just finished the foundation course and started the level 2 Orchestrator course where I got this problem. It seems from all the posts Orchestrator on community version is unstable. The rebooting of laptop and restarting Orchestrator worked for me but may not work for everyone.

hi, we are now experiencing this also with our UiPath Enterprise.
Our scheduled jobs are delayed by 30mins to 1hr.
! set Job1 to run at 1AM. At 1AM, you cannot see it in the job running and will only start around 1:30-2AM please help

Hi @rpa_automation

This issue was fixed by our team.

1 Like

Confirming issue has been fixed. Just updated to new version, no issues so far

1 Like

Hi, we are again experiencing the issue. Scheduled jobs are delayed ~1hr, no issues when running manually. Are there any maintenance ongoing?

We are running on 2020.4.3

@loginerror I believe this issue persists or has reoccurred. I have been scheduling jobs since June 2020 and for the first time, I noticed the orchestrator skipping a perfectly scheduled job this morning. The relevant host machine, robot, environment were all online. Infact, the post and pre jobs (different) ran well.

11 PM job ran.
4:15 AM job skipped!! - No trace of it anywhere in the logs, etc. Did not even trigger.
5:00 AM job ran.