Bot stuck in 'Running' status with no exceptions

Hello,

I am running into a problem that I cannot figure out. I have seen a couple similar issues on the forum but haven’t found a solution yet.

I am starting an automation from Orchestrator with a large batch of data to be processed (expected to take about 15 hours for bot to process all queue items). Logs will randomly stop populating in Orchestrator. It’s like bot gets stuck on one activity and can’t continue. However, bot does not ever timeout or throw an exception. It just continues to be stuck in ‘Running’ status with the same log message.

For example, in the picture below, bot had been stuck with the last message ‘clearing edge cache’ for hours with no more log messages being populated. The longest we have let it run without restarting is 5 hours. However, it doesn’t always get stuck here. The majority of the time it goes through that activity in a matter of seconds, moving on with no problem. Stopping the job and restarting has always solved the problem but is obviously not ideal.

Has anyone seen this before? I am wondering if it is some kind of a connection issue?

In my experience and assuming you don’t have an infinite loop situation, the bot getting stuck on a single activity that doesn’t time out is usually due to some unexpected behaviour from an application which halts the UiPath code execution.

What is happening in your code immediately after that ‘Clearing Edge Cache…’ log message?

Have you tried logging in to the robot machine to see what’s happening on it’s desktop at the point in time that it’s ‘stuck’?

Immediately after clearing the cache it is supposed to open Edge with the URL of the site we are using to process the data. When we login to the desktop the bot runs on, it is stuck with just the default Edge browser open…not doing anything.

@moosh

Hello @kasey.betts

Will it be due to system capability? Can you check the memory utilization in the task manager during the execution get stuck. Also is it happening only in the cache clearing step?

Possibly but we have run this automation with no problems like this in the past. We recently had to switch from IE to Edge and now are seeing the issue.

Yes, It only seems to happen at the Clearing Cache Activity

@Rahul_Unnikrishnan

Hello @kasey.betts May I know why you are trying to clear the cache

yes, the site we are logging into sometimes does not respond and if we do not clear the cache, the next time we login it automatically takes us to the error page/remembers the credentials and logs in automatically. So before logging in we clear the cache then open a new browser and login.

We have run into problems around the site thinking there are duplicate logins because something was not responding so bot didn’t logout and needs to restart.

As part of automation are you log out from the application as well?? I think if you properly logoutbwith automation it will not redirect again in the next execution.

Thanks. When you say default Edge browser, does that means it hasn’t even opened the expected website yet?

Also have you identified which activity in your code the bot is stuck at? E.g. do you know if it’s the open browser activity, or something nested inside that?

Can you share your workflow/screenshot of it?

yes it is meant to logout and it usually succeeds. But we were running into an issue where sometimes the application was not responding and the only way to fix it (even manually) is to close the page and clear the cache and login again. Just refreshing the page does not work.

Correct, it hasn’t even opened the expected website. I have included screenshots of the activities right before and right after the last log message recorded in Orchestrator when bot typically gets stuck

image

Not sure if that first image uploaded correctly

Can you provide a screenshot of that retry activity properties?