Read Range not working with varaible row numbers

The read range activity works when the range is short like A1:J1 but tells me

when i do A1:O1,

Please what could be the issue and a solution to it?

Hey @John_Dara

Apparently there are two columns named “370000” in your Excel file, which is what causes the error - the column names in a datatable should be unique.

But that “370000” looks more like a value than a column name. You can also check whether you are using the “AddHeaders” option correctly in the “Read range” activity.

Hey @alin.c.mihalea
All the headers are not even numbers but If i use a shorter range it works

Please share the excel file, so I can take a look.

In READ RANGE activity disable ADD HEADERS property and try once

The excel file actually contains two different cells with the same values but different headers so i used two read range activities but can’t seem to add their output to the data table i’m building

Hi @Palaniyappan, @alin.c.mihalea
I’ve been able to use the read range and for each row activity to iterate through the details to get certain row items but trying to add the out put into a data table isn’t working, Please what can i do?

If the columna are named differently, you should have no problem reading the whole excel in only a read range.

If some columns are named the same, a workaround would be iterating through the column names and renaming them like “columnName_1”, “columnName_2”. I can help you with a workflow to do this, if this is the case.

Please upload the excel file so we can take a look.

@John_Dara, the excel, not the Xaml.

I tried the Read Range activity on Test Data.xlsx from you and I had no error - “Add headers” checked or unchecked, both worked. Do you still have that error when reading it?

yes i do, i want to add the output of the get row activity unto the data table and write the data table unto an excel file