RE: Question about Web Service Library

I’ve experimented with this example and it works fine.

However i tried to implement this in a project and it is currently not working it only gives me the error Message: Object is read-only.

I’ve also tried using the SOAP activity however the error that it gives is different it says that i’m triyng to authenticate as “Anonymous” (I´ve tried Basic and Windows Credential Authentication) and it should be “Negotiate,NTLM” can someone help with this please? :grinning:

Hi @tfilig

I am not sure I understand.

At which point do you get the error message?

1 Like


I executed the activity and it gives the error.

I’m trying to connect to the a mail archiver web service.

Thanks for the response.

I made the topic public for everyone to be able to help you :slight_smile:

A screenshot of the process and the issue itself would be a good start.

1 Like

So i’m triyng to make a request to a web service through the service i have imported, however every single action i try to call gives this error:

I have also tried to use the SOAP Request Activity, however the error that shows when i try to execute the process is this:


In both cases i have tried to use Basic and Windows Credentials but it gives the exact same messages

Thanks for the help :slight_smile:

The following link may shed some light on the error message.

I am sure that it is about the security settings of your service.

Please check -

But i’m not able to change the security settings of my server, i don’t really see how can i implement the changes talked in the link , using the http or library activities.

Do i use the headers of the request it ?

Thank You for your help!

I am having the same trouble. Have you fixed it? It’d be great if you could share your findings/solution for this issue.
Thank you.