SOAP Request

Hi Team - I’m trying to invoke SAP Webservice in UiPath using SOAP Request activity.
I’m getting error “There was an error downloading”

Please help.

Hi Leema,

Please try with http://www.webservicex.com/globalweather.asmx?wsdl and let me know if you get the same error.
Also, can you double check the credentials(i’m thinking maybe it’s bad username or password) for SAP?

Hi Leema, were you ever able to get past that error?

Ovi, I am getting the same error if I try with the WSDL you shared.
Any help/pointer would be much appreciated.

Thank you!

hi ovi,
using this URL also getting same error

I have reported to QA team to investigate. What UiPath.Web.Activities pack version do you have? Also, are you just testing the activity or are you trying to invoke another webservice?

1 Like

Ovi, I am also facing the same error. I have given correct wsdl endpoint & credentials in Soap Request
Using Version of UiPath.Web.Activities : 1.1.6382.14556
image

Please help in resolving this.

Hi @AbiS

Could you try with the newest version of the activity package?

Thanks, but I am unable to update it to version 1.4.
When i do, I get this error "Unable to resolve dependency ‘Microsoft.CSharp (>=4.3.0)’ ". How to resolve this?

Please make sure you have this feed added:


https://api.nuget.org/v3/index.json

Do we need to update this in settings under Manage Packages?
I am unable to find the option. Is it due to the UiPath version? Please let me know.
My version is:
image

See here:

image

I tried the steps… Facing below error

The url i load gives me ‘invalid error’. Pls help me resolve this. Am unable to add each package
manually, as they are many in number

This is strange. Would you mind trying it out without https:// in the beginning?
api.nuget.org/v3/index.json

But I suppose it should work. I would definitely contact our support with the main issue though, they know most of the answers and can easily check things on the previous versions.

Ok, tried it without “https://” , but got same error. Kindly let me know, if you have any update to resolve the issue

Hi @AbiS

At this point, I would definitely contact our Technical Support for assistance.

We are not sure if installing the new version will fix the original issue and they might be aware of another solution.

Thanks, So I tried alternative way by browsing wsdl file using ellipsis in Soap Request activity. The contracts have loaded fine but when i invoke, i get this error

SOAP Request : Method “ServiceClient.MethodName” not found
How to resolve this?

Unable to get any way to do. How to resolve this
image

Mac, Any updates on this, pls ?

Hi @AbiS

Actually, since 2019.4 there will be a dedicated service for consuming SOAP requests. See this post/thread:

With a slight correction in this post: