Queue the Transactions are still In Progress

HI All,

Some times in [Orchestrator] Queue the Transactions are still In Progress but they are already updated the Data Base and finished the actual process.

Did not clearly understand why the those (few) transactions are still In Progress.

In the machine no process is running but the queue transaction status is In Progress.

Can somebody help me to understand the reason behind this scenario.



If you are using Re Framework, your queue items status is set to “Success” after the processing but you may get an error before setting the status of queue and after processing, this may lead to the queue item as in progress.


Can you confirm that there is no error warnings in your output panel?

Sometimes there will be some error occured before setting set transaction as success and bot runs for the next transaction

NO, There is no error occurred. Bot is able to pick the next transaction and going for success but still last transaction is INprogress.

@RobertRajaSundar ,
yeah that means set transaction status under success is not working … or bot is not able to reach upto the activity

I’m not able to find the exact reason, If we process 200 records around 10 case stuck in inprogress in queue.

Any updates ??

I can notice orchestrator slowness sometimes and there is a “” Timeout Issue “” facing in orchestrator.
That time the processing records are getting stuck in inprogress.

Can someone share the solution for this issue ?

I am also facing the same issue 5/109 failed with below error messages

Set transaction status (Business Exception status): The operation has timed out.
Set transaction status (Successful): The operation has timed out.

You’re having an Orchestrator issue. I bet you aren’t regularly clearing out your log table, and the database is huge.

That is not correct, the error I am getting is from a brand new environment and there no much processes deployed. Anyways take a look at the log table.

Then there is some other issue causing Orchestrator to have performance issues. As a bandaid, you can put the Set Transaction Status into a Retry, but that’s just workaround - you should still troubleshoot the Orchestrator issue.

Hi @postwick – We did many troubleshoot things, But nothing worked…

Then I suggest contacting support.

contacted but nothing worked :frowning:

Any luck ?
even am facing this issue
can anyone provide the solution for this issue?