Promoting a project from Dev to Prod, and getting an error when running


A guy in IT has uploaded a packaged to our Prod orchestrator (after it was tested in Dev) and it appears to have gone correctly, and that the assets were set up as well. However, when our end user tried to run the job, they got this issue:
The logs suggest nothing ran at all, it didn’t even reach the initialise phase properly? I have checked the email settings in both Orchestrators and they appear identical, is there something simple we’re missing? Please help me troubleshoot.




The UiPath.Mail.Activities is not being fed into that machine.The Official feed should automatically be configured for the machine, but it would be set up in “C:\ProgramData\UiPath\UiPath.Settings” I believe (if might say Access Denied). Make sure that the Send SMTP used is from the Official feed also or other machines can’t find the activity (this most likely isn’t the issue).

Also, make sure the Project Dependencies when you open the file in Studio has UiPath.Mail.Activities listed (also listed in the project.json file), and republish if you needed to install the dependency from Manage Packages. If it is already listed, make sure you have the latest version installed from Manage Packages. - I have seen some instances where the version installed was not in the Official feed, so updating to a version listed corrected the issue.



Thanks, will try these tomorrow and hopefully one works. We didn’t want Studio on the Prod VMs if possible, seeing as business users etc have access, as well as the IT staff who promote code to live - although they won’t have access to Orchestrator to promote the latest process they’ve published if they try anything dodgy - they could still run from Studio. Is there a way round this, or have I misread your suggestion?

When I said to check the dependencies in Studio, I meant on the development Studio and not the robot machine. If the dependencies are correct and from the correct Activity feeds (like Official or Community), then the robot machine should not get that error you received, but only if the robot machine has the feeds correct in the UiPath.Settings file like I mentioned.

I’m suspecting that the version on your dependencies is not found in the Official activity feed. If that is the case, then you would need to go to Manage Packages and update the Mail activities to a version in the Official. Then, Publish again (and Update in Orchestrator) - hopefully, it’s just that simple, though!



It might need updating but it worked before on both my laptop and other VMs and laptops, but I will try that anyway. I also tend to only go for UiPath packages even within Official, and avoid community/others because I used to be an auditor so I’m extra prudent :smiley: That may likely change going forward as I see more and more useful ones (side note - perhaps UiPath could show number of downloads/ratings for other ones?). The .json also lists the official package.

I’ve checked the UiPath.settings file and as you suggested, it said access was denied. Could an admin check this file, or is this locked by design?

Hi Alex - 1. Please check package name and version in project.json file which can be found in project folder on the machine from where you published the project.
2. Copy the nupkg file from %userprofile%/.Nuget/packages//
3. Paste it in nuget feed of Orchestrator (Default location /NuGetPackages\Activities)
You should be good.

1 Like

Thanks, I emailed my IT about 3 minutes ago with that request (no admin rights for me :frowning: )

When checking the process I updated to 1.30, so it now says “UiPath.Mail.Activities”: “[1.3.0]” in the json file, but in my project I was originally using 1.2.6… - so that’s the one I should copy to the Orch/NuGetPackages/Activities on the Prod machine correct?

Yes, you need to copy what is there in project.json file as robot reads the dependency details from there only.

Perfect, also, to note, I had to create the Orchestrator folder structure on the Prod machine - I thought this would be there automatically?

Ideally, Activities folder is being created while installing Orchestator. Not sure what happened in your case, someone might have deleted the folder by mistake.

Please close the thread if you are fine with the solution.

I will do, just waiting for Business to test, thanks :slight_smile:

I have tried running the file again, after getting IT to whitelist the above mentioned websites and copy the nupkg file into the new location. Is there anything else we can try?