Programme still running despite execution ending


#1

Hi all

I’ve noticed this quite a bit today and I wondered if anyone else was having this issue.

I’m running a programme, it ends, but it’s still showing as running. I’ve realised this doesn’t make a lot of sense so I’ve taken a screenshot (I moved a few things around on Paint so the shot didn’t take up the whole screen):

It ended at 17:07, however the “Stop” button is still active. When I click on it, nothing happens. When I try to close Studio, I get a message box saying “There’s a robot that is executing. Wait for its execution to terminate or cancel it before closing Studio”. I have to start Task Manager and close Studio that way.

Is this happening to anyone else? I have version 2017.1.6522.


Studio Execution Gets Stuck?
#2

This happened for me also. I was able to narrow it down to an issue with reading in an excel file, specifically a certain worksheet within it. Unfortunately I wasn’t able to confirm exactly what the issue was but removing a blank column seemed to solve this for me.


#3

I encountered this as well. anyone found any solution so far?


#4

Not yet, we are working on a fix.


REFrameWork execution is not ending even after all processes are completed
#5

just some feedback, i manage to find root cause of my case. apparently i put too much writeline (for debugging purpose) for each row in Excel. Once i remove those writeline, it was working fine.


#6

Thank you. We know the root cause and we will provide a fix soon.
I don`t recommend doing Write line or Log message activities if the size of the text to be logged is bigger than a few lines, for this you have the option to output to a file (text, csv, excel etc) and that will work as expected


#7

My programme doesn’t use writeline or log message activities. It uses read range activity (workbook) and I have the same issue.

Also, when a excel cell is too long, there is an abnormal termination in uipath. It doesn’t matter how many rows or columns there are in the excel file.


#8

Can you share the project (excel file and workflow)


#9

Hello, have you found a solution already? Thanks in advance for a Feedback.


#10

I have been struggling with the same issue for a couple days. Finally got it fixed.
I have a workflow decision, and the true path logs a message as the final step. I ended up simply putting the log message into a sequence, and the bot now stops.


#11

Hello,

Did you get to solve it?

Thanks!


#12

Hello

Nope.

A way around it that works for me is putting a delay of around 5 seconds at the beginning. I found that the type of processes that were having this issue were really short ones, so UiPath Studio would lag a bit, the process would complete, UiPath Studio would catch up and try to complete the process that had already been completed.

Not sure if it’s a proven salutation but it does the job for me!