Unexpected Process Termination when using "Write Cells/Range"

Hi all,

My project contains 3 sections where I need to “Write Cell/Range” and every time it causes UiPath to break and give me an error message (copied from a similar topic so job name is different, otherwise the same):

Essentially the process goes into 2 excel files, manipulates the data slightly, reads the ranges into datatables, then should paste them into a third excel file.

When I comment out one Write Cell section (which works on it’s own when not part of the larger process), it will proceed past this point, and then it causes the same error message at a later stage when I “Write Range”. On the first part, where Write Cell is used in a loop it will actually do about 10 or so (out of 30) before stopping, but on the Write Range it just won’t budge. I’ve seen mention of message sizes elsewhere, and that on latest versions 1MB is the maximum, but as I know this component works elsewhere is it perhaps the 3 datatables which are being stored are “too big” somehow?

Not sure what else I can do unless I chop up the process and change when the datatables are written so that they do not need to be stored in memory?



Hi @Alex_Cross

I will start with the standard formula :slight_smile:
What is your version of Studio and the Excel activity package?
If possible, have you tried to update both to see if the behaviour is still present?

Thanks for your reply.

Studio is 2018.3.1, and Excel is 2016. As I work in a large company I can’t update Excel, but I will put a request in for Studio to be updated.

Although as stated, this component works when it is is on its own, just not when in a larger process?

I meant the Excel activity package in your Studio:

It might be that a simple update to this activity package will solve this issue (if it was already spotted and fixed).

Please also log a support ticket to track this issue.

It would also help if you could test your workflow with a small sample Excel file. To debug it, I would try to eliminate the possibility that the Excel files themselves are what is causing the issue.

I’m using 2.1.5, and have played around with a few files and it seems to work, but I will keep going, as perhaps the main file is somewhat “different” (which wouldn’t surprise me as when I copy in 30 lines of data (only 8 columns) the file jumps from 1.6mb to 52mb…).

I will also raise a ticket, thanks