Problems after 18.3 upgrade with REFramework GetAppCredentials (Catch)


I upgraded to 18.3 and started the advanced coursework again. I haven’t got very far as yet, I was looking at the GetAppCredentials which is throwing errors, see below.




Here is my GetAppCredentials workflow (which I haven’t changed myself, these errors are in the Catch part).

GetAppCredentials.xaml (13.1 KB)


@charliefik Delete your json file and run

Thanks for the suggestion @indra but that didn’t seem to work. I deleted the JSON file I had associated with my project and then double clicked the GetAppCredentials xaml in the Framework folder. It then creates a JSON file in that folder but I still have the same red error messages.

I then tried deleting that JSON file and opening other workflows in the same project creating other JSON files but that didn’t help either.

Have you upgraded to 18.3?

Could it be anything to do with missing packages that weren’t added with the 18.3 update (I don’t know just clutching at straws)


It seems to be having issues with the following 3 activities

if I go to my activites window and type credential there is a Get Credential activity but if I look in the properties window it’s UiPath.Core.Activities.GetRobotCredential

I’ve got a feeling that this may have changed in the update (but I can’t see as I don’t have the old version any more)



@charliefik Go to package manager and update UiPath Windows Credential Store Activities and
Uipath Core Actvities and update others also


Hi @charliefik

The suggestion of indra to reinstall the required packages is the correct one. I had this exact issue at home with very basic workflow. It would not recognize the activities it needed.

I think it has something to do with the split of activities into different packages that was mentioned in the change log.

I also believe it to be a bug of the conversion tool that misses some dependencies when first opening the old files with new version.

1 Like

UiPath.Credential.Activities was not added (so I uploaded it)

Couldn’t find UiPath.Core.Activities but I’m going to install all the UiPath packages for a start.

Thanks very much @indra and @loginerror for your help

1 Like

I thought that I would only have to download the packages once (and then they would be there for good). However whenever I open REFramework (which needs to be converted)


I have to reload all the missing packages again (which is quite a pain). Is this normal behavior?

If I open up a new blank project I just have 4 pakages

I’m not `100% sure but I thought the idea is that you download packages and then they are available when you want them along with their associated activities. If there are no dependencies in your workflow with certain packages then they won’t be used but I didn’t think you had to download all additional ones (to the original 4 each time).


You are correct, it was mentioned in this topic:

It seems that the new projects get default set of packages that cannot be changed. But then again, it is a beta, so it will probably be added :slight_smile:

1 Like

Thanks again @loginerror as usual you are omniscient. Are you wired into the UiPath servers?


Hi charliefik,

Quick question, any chance you still have the version of Studio this workflow /project was created with ?
We do strive to create a seamless transition to the newer versions of Studio and eventual Activities packages, but if we missed something, I`d like very much to investigate.

Also, a quick mention, I also got the workflow to work when I installed the Uipath.Credential.Activities pack (UiPath Windows Credential Store Activities)

Hi @Ciprian_Forcos I’m using the CE edition of Studio. When I upgraded to 2018.3 it looks like all my old versions were completely removed (I can’t find them and only the 2018.3 version is there, I had a shortcut to the original folder but that stopped working after the upgrade). Previously when upgrading there has been a version folder in the UiPath folder and when upgrading a new version folder is added.

The workflow is the REFramework project folder that I downloaded months ago from github (I keep a clean copy which I copy and then work from as a starting template) . So whoever built that version and put it on Github probably has a better idea of what version it was created with.

Sorry I couldn’t be more help.

One more thing, As the REFramework is supposed to be the starting point for all major projects and it requires the credential package, doesn’t it make sense to include that in the default packages that are automatically there when you open Studio?

I personally don’t like that every time you start a new studio you have to reload the non default packages.

Hi again Charlie,

That makes sense if you manually installed the CE .exe file. Double clicked the thing and installed it.
This process does indeed uninstall previous versions you had installed.

The way you would keep older folders on your machine would be if you let studio automatically update its version.
Either way, the older versions of Studio shouldn`t be available for use (unless you tinker about in the folder), as the newer version takes precedence.

Many thanks for the details on the REFramework wf. I`ll have a look.


I am getting error ‘Activity could not be loaded because of error in xaml file’. I have reinstalled the required packages. Still the issue exists. PFA.I am using 2018.2.3 version Community edition.Can you please help me to get this resolved. Thank you


Hi Sonali,

You need the Excel activities package there. You`ll find it in the package manager under UiPath.Excel.Activities
The current version is 2.3.6682.26635

Hi @Ciprian_Forcos,

How did you know what package sonali needed to add?

In my problem there was an output screen showing which activities were causing issues (they were all credential related), so there was a good chance that the problem package was also a credential package.

If the naming is not so obvious how do you know which package to add? Also in sonali’s case there is no output window in his screenshot and the problem activity is just red how did you know it was the Excel.Activities package that had to be installed?

Many thanks,

Well, a bit of experience, and a bit of digging arround I guess.

I opened the same wf he did, but with Notepad++.
I navigated to the last visible part of the Wf in Sonali`s screenshot (which is the IF activity),
then I saw the excel application scope activity in the file, and I know that it requires the Excel Activities package.

Thanks Ciprian. It worked. After renewing the version I had forgotten to install all required packages again.
Thanks again.


Ah thanks @Ciprian_Forcos, I didn’t know about the runalltests.xaml in the REFramework Test_Framework folder (I’ve never used it, I thought that was something Sonali had created and couldn’t see how you analysed it from a screenshot) If I wanted to do testing I’d put invokes into the _Test.xaml in the top level folder.