Get OCR text activity returns empty text when we change workflow to another system with low resolution

I have used “Get OCR text” activity to retrieve specific data from invoice. My workflow is in the system having resolution “1920 * 1080”. When the workflow is moved to another system lower than my resolution e.g. 1680 * 1050 , the OCR activity returns empty text. I have tried changing UIpath setting file, Orchestrator screen resolution setting, Launch workflow interactive. It has no effect at all.
If anyone else have any experience with this please comment.
Thanks in advance! :slight_smile:

Welcome to the Community!
Have you tried to open the workflow on other computer with lower resolution and indicate the target for Get OCR Text activity again?

Yes, I have tried to open the workflow on other computer with lower resolution and indicate the target for “Get OCR Text” activity again. Is it necessary to indicate the target element every time when we move workflow to lower resolution system?? Is there any other way to solve this problem?

Similar problem is sometimes happening also in citrix workflows because of different resolution exactly. Here’s an example for solving it, but this requires to use Orchestrator. Please have a look:

Tried messing with all of the resolution settings on the PC , Orchestrator and UIpath setting file, nothing changed.

Sometimes you may need to include in your workflow scenarios for different resolution.

What we need to include in our workflow?? I have also tried “Launch workflow interactive” where we can set resolution within the workflow, nothing changed.

1 Like

Please check the solved topics, there are some useful information with similar problem:
Especially this one can be helpful:

Thanks for response @Pablito . I have tried all of the resolution setting,nothing changed till now .I am scraping part of the pdf document but when the robot run in different machine with difference monitor size, the output is not the same or return empty text.

1 Like

Hmmm, maybe you could try to process PDF and make image of it, and then try to do OCR from the image. Just my thoughts :slight_smile:

Thank you for the continued answers; but my need is to be able to read data from a specific location on a document; And I will need this to work on different systems - Development team members, QA and Live. So is there a way to extract data successfully from specific location on PDF even when resolution changes?

1 Like


Basically, if the robot is supposed to run OCR on the specific resolution, then you will want to develop, test at the process at that resolution. OCR is really sensitive to any changes in resolution / scaling, so these should be ideally the same at all stages of the development.

You could still try this method though:

It might even be more robust and/or quicker than OCR.

Hi @loginerror
I have attached specific area of sample invoice pdf for your reference where i want to get the “Purchase Order Number

The following image is the output for “Read pdf text” activity

And the following image is the output for “Read pdf with OCR text” activity


In this case we can’t able to apply string manipulation or Regex expression. Is there any other way to get specific field from pdf successfully

I think the first one still allows you to extract the data based on the string itself. This will of course depend on whether the structure stay the same between different PDFs, but you could use regex like this one:

See this example project to see how to extract your value: (2.0 KB)

I have several invoice templates e.g 440 where PO number present in different position. Simultaneously i have to retrieve nearly more than 10 fields like Invoice date, Invoice Number, PO number ,Order Number, Customer name, Carrier name,etc… For each field and for different template using regex is complex.Thus am moving to “Get OCR text”. Is there any other way to extract data successfully from specific location using OCR activities from PDF even when resolution changes?

I believe you could try the Computer Vision activity package, like so:

I’ve used your screenshot from above to do that, so I’m sure it would work much better on the actual PDF file :slight_smile:


Thank u @loginerror , Computer vision is working good in different resolution :smiley: .But,the problem i face in CV is some text are not recognized in CV scope. I have attached the sample image for your reference.
In the following sample pdf image, CV recognize the “Reference#” number.

In the following sample pdf image, CV does not recognize the “Reference#” number and returns empty text.

Simliar case in the following region too,
Not Recognized:

In this case too, not recognized fields return empty text. Is there any way to solve this problem.

Unfortunate, it might be that the engine doesn’t recognize the text there, which would be weird. It does recognize all fields for me based on just your screenshot.

You could try refreshing the scope with this button:
(it shows when you indicate element with, for example, a CV Click activity)

Thank you @loginerror, after configuring OCR engine again, it works good :slight_smile:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.