Problem with publishing the Hello_World excercise

Hello all!

I was starting my RPA learnings and installed Studio, started folowing the Hello_World excercise, but when I try tuo publish it there isn´t a Orchestrator to choose from the Publish to -menu.

When I first registered to UIPath´s website I used my license from the school. Then the video told me to invite a another tenant (user/developer) so I invited my personal email, because my schools email was already registered as Admin of the said Orchestrator “group”.

It seems as if my StudioX, Orchestrator and the assistant wouldn´t be connected. Because I managed to publish it locally with the pictures options, and it ran okay, but I didn´t get the Hello_world to my Assistant.

Hi

Welcome to uipath forum

Have a view on this doc for publishing projects in studioX

Publishing Automation Projects.

Cheers @Teemu_Tormala

Thank you for replying @Palaniyappan

I checked your link, but it didn´t resolve my issue, just made me understand it.

I can´t seem to connect the robot or the studio to orchestrator. I tried adding the URL and the key to Assistant, but it came with this error:

image

I found a thread about this: There Is Not an Orchestrator Present at the Indicated URL Please check the Link and Retry It suggest´s that the reason is that Robot was installed in user mode.

I don´t understand this, because I´ve uninstalled the program couple of times and made various user´s for my “organisation”, but that didn´t resolve the issue.

Hi @Teemu_Tormala,

Please check with the below steps and verify whether you have the same.

  1. Login to cloud.uipath.com and navigate to the appropriate tenant suppose if you have more than one. (Click Orchestrator → Select the tenant [reference screenshot below])
    imageimage
  2. In the URL, you can notice the link will be in the form of cloud.uipath.com/orgname/tenantname/orchestrator_, So copy that link from cloud.uipath.com till orchestrator_.
  3. Open your assistant, click Settings → Preferences → Orcehstrator Settings. In that screen, check the connection type whether it is Service URL or Machine Key.
    If it is in the service URL, then try to signout and sign in again and also in the studio sign out and sign in.
    And now, try to again publish it.

Let us know whether you’re able to achieve it or not.

Regards,
@90s_Developer