Problem with Invoke Workflow File

I’m trying to decompose my robot into reusable sequences to favor reusability and my main.xaml file doesn’t look so loaded, I’m trying to test the Invoke Workflow File activity to invoke my reusable sequence and when compiling the file main.xaml it gives me compile error and tells me: An unexpected error occurred during the library compilation process:
Object reference not set to an instance of an object.
Please someone from the community who can help me with this.

Hi @datamart

Object reference not set to an instance of an object normally occurs when a variable is null. Try passing the variable and arguments correctly to resolve the issue.


As a test I have tried to invoke a sequence that only shows a Message Box with a text without using any variable or argument and it gives me the same error

I share here images of the configuration of the arguments and the variables of the file that I want to invoke!

This is where it is called in the main


can you please open the studio logs and check teh error from there…that would give more info

also analyze the project once so that any errors in xaml will be highlighted

it might be some imports are missing or wrong…check the imports panel as well


Hi @datamart ,

Could you check the below workflow which discusses the same issue :