Main workflow cannot be executed - Object reference not set to instance of an object

Hello everybody,

I implemented my process in in the main sequence with a lot of subsequences. Then I tried to invoke new activities with a flowchart and since then, the main workflow can not be executed anymore and I get the error "Object reference not set to instance of an object.
I have been trying to find the error for hours now and also deleted the new flowcharts, but I still get the error.
Unfortunately, I am not allowed to post my process flow.

Does anybody have experience with this or knows, which variables I should check?

Thank you!

@silvia93 You can Debug the Workflow and find the Activity Which throws the error. The Error that you have got usually states that the value is not Supplied, or a value is empty and cannot be processed further.

Thanks for your fast response.

I already tried to find it out with debugging, but the error appears right at the beginning after I started to debug. Thus, the program didn’t process any variable yet.
It’s also weird, that I only get an error when I run it as test activity.

I have also faced similar issues.

Try to see if you have created multiple arguments of the same name - different data type, or else delete the arguments and create it once again.
Import it again and assign the values.

Hope it helps.

That’s a good hint. Thanks!

@silvia93 Doesn’t the error Specify the Activity name when it is thrown ?

Unfortunately not. It just specifies “Generated” and no specific activity.


Hey @silvia93

Please may you show us what your watch and local pane look like when you debug and get the error? It should show us which variables are null

It might also help us to understand exactly where the error is occurring.

The error you are getting means that somewhere in your workflow a variable, argument or property (that is required for use) has not been set and thus, is null.

Based on where it is occurring, we might be able to identify what is null (variable, argument or property)

Finally, I found the error. In fact, I had two variables with the same name.

Thank you all for your support! :slight_smile:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.