Printing as a pdf in Adobe Acrobat

Hi there. I am extremely new to all of this - But I am using Uipath Studio my work provided. I have come quite a long way though and have been able to fix an outdated bot a colleague made last year. Well, I have fixed 99% of it and am caught up on the last step.

My bot has completely filled out a PDF to my liking. I have it save the PDF just fine. But then I need it to actually print a PDF file to a local folder. (This is different from saving, I need it to be a flat pdf without the fields editable). All the steps in my bot are correct, I am very confident about this. The issue seems to be that when the bot clicks “PRINT” in the print dialogue box the next step is for it to type in the file name and file path to save to in the “Save PDF File As” dialogue box. For some reason though, that dialogue box never shows up. When I do this myself manually, it does show up.

I have a feeling that my bot is proceeding to the next step faster than the dialogue box can pop up. I’m not sure if this is possible but I can’t think of anything else. Does anyone else know why this might happen? Thank you in advance.

If you suspect that the bot is going too fast before the “Save PDF FIle As” dialog appears, you can try to put some delay in between or better yet some activity “element exists” to check if the dialog box is already visible.

Thank you so much for your suggestion. Taking your advice I did both the adding of a delay and adding the “Element Exists”

I have learned that the “Save PDF File As” dialogue box does not show up at all when the box runs up to that point. This is very confusing because it does if I go through the steps myself manually.

Does anyone have any idea why this might happen?

I know that I am properly initiating the print because when the “Print” button gets pressed in the print dialogue box there is another dialogue box that pops up (that requires no interaction) called “Progress” that shows that the file is is being printed to pdf.

It’s just bizarre that the SAVE PDF FILE AS box never shows up when the bot is running.

Has anyone ever experienced this.

That was really strange as I have created a short test process to simulate and the “Save PDF File As” appears for me. Can you share your flowchart or sequence? Another suggestion I can give you to try and troubleshoot is to cut your flow/sequence at the part where you click “Print” (like ending the process there). So you can see if the “Save PDF File As” don’t appear or it appears but might have been clicked trough by your next steps/activities after clicking “Print”

Thank you for your help with this. They are not letting me upload files to this forum because I am a new user, otherwise I would share with you a simplified sequence I created as an example. (The larger project file is actually a product of my employer and I am afraid getting in trouble for sharing the whole thing)

Not sure if there is another way to show you.

I did follow your advice though and cut the sequence off at the problematic step so that the sequence should end with just the “Save PDF file AS” dialogue box open on the screen. It still does not pop up though. It’s so weird.

It looks like the forumn will let me add a picture:
unnamed

The bot gets to the point where the above dialogue box generates. This is telling me the bot presses “print” properly. I am just not sure why the SAFE AS dialogue box does not open.

I have no issue with the SAVE AS box opening up when it is a regular save initiated using CTRL + SHIFT + S

DO you think perhaps there is any way you can share the test sequence you said you made and confirmed to work? I can run it on my machine - if i run into the same issue then it must be something unrelated to my sequence. If it runs successfully I can trouble shoot the differences in out file.

I appreciate your help

Sorry, same situation with me. I have just recently participated in the forums so I can’t attach files yet. Its a so short test flow anyway

The “Send Hotkey” activity is just sending “Ctrl + P” and the “Click Image” activity is just clicking the print button. But when I run it (with the pdf file already open), the “Save PDF as” dialog appears. I am using PDF exchange editor.