Handle "Save as" window


#1

Hello everyone,

I’m working as a trainee in a company. They want to automate tasks that require to save PDF files.
I’ve just installed the program so I don’t know everything about it. we are testing it in order to buy the licence, and use it in many agencies.

Actually, we print the documents as PDFs, so Adobe (we use Acrobat Reader DC by default on every computer) creates a temporary file and opens its preview.
Then I am able to click “file”->“save as…”, or even do a CTRL+SHIFT+s .
The problem is that I cannot handle any element of the new “save as” window that just appeared.
I used a “ON ELEMENT APPEAR”, but the event is never triggered. I also can’t click on buttons, change destination path, and change filename before saving it.

I don’t post any screenshot because I hope that I explained my problem clearly enough.

Thanks to every person who reads my post, and kisses to them who will reply <3


#2

@Dray,Use Attach window and capture the screen of SaveAs and Type your inputs in attach window.Hope this will sove your issue

Thanks,
Sreekanth.k


#3

If you are saving the PDF document by using Save As window then the following selector will help you to enter the file path in the Save as window.

image


#4

@sreekanth, this did not work :confused: but thank you a lot for your answer :slight_smile:


#5

Once try with try Element exists @Dray


#6

already tried, this is really weird… thanks btw :confused:


#7

Can you share the xaml file if possible


#8

YESSS, I managed to fix this by using the two methods ! I tried something desperatly. Thanks to both of you, you made my day


#9

Hello Dray, don’t keep the solution with you… please share with community…
Community will always appreciated you.

Happy UiPathing… :slight_smile:


#10

just came back ! I thought it worked because the opening event got triggered… BUT… there is still no way to type into the fields…

Of course I will share the solution if I find it don’t worry :slight_smile:


#11

please use the same selector for Type into Activity. When you open Save As dialog… default focus will be at File path edit location.so just take Save As Dialog selector for TypeInto Activity and post full file path to save the file.


#12

@Dray provide some delay and Try with get active window and type into it


#13

@rkelchuri the default field selector is at file NAME edit location and not filePath… In fact, the only way to reach this field is by its title… but his title is also the adress it contains…

image


#14

ok then make it general with *
title=‘Enregister*’
title=‘Address*’


#15

Hi @Dray,
Use attach window activity then select the selector.

If dynamically changing use * in the property.

Regards,
Arivu


#16

Worked perfectly. Thank you a lot. I didn’t know this tip. The solution was to use " * ".
have a nice day !


#17

Hi @arivu96
I am facing a similar problem. I tried the method of referring to the same selector(using *) which is pointing at the file folder path. But i don’t know why the type into activity is not working. The click activity works but it is so weird that text cannot be typed after that.
Can you help?Thanks!