Orchestrator very slow when run process

Hi Everyone.

I have an difficult issue and dont know why and how to fix.

I have a project and run its source code on Local Machine , it run about 20-30s… but when i publish it into the Orchestrator and run, it run about 7-8mins.

I have tried to do some steps:

  1. Clear all of old packages on Orchestrator and publish a new one.
  2. Upgrade all of packages dependencies to the newest.
  3. The network connection is good
  4. Disconnect connection to the orchestrator and re-connect sometime.

I have checked and known it slow when ran from orchestrator at For Each Row activity. One For Each Row inside of another For Each Row. I have disabled ( comment out ) all activities inside of the For Each Row Loop and try to run but it still very slow from orchestrator… but on Local Machine always fast when run.

Any one has any suggest or solution for this case?

Thanks in advance!

Hi @Mr.H,

Duplicating the same issue won’t get you an answer sooner. Best practice is to continue your troubleshooting in the same thread, that way forum members who are trying to help you can read responses from other members.

This question is a duplicate of : Run project from the orchestrator very slow - But run code directly on the local machine fast



For debugging, you can place a writeline activity after the activities you have and write Now.ToString

This will let you know how much time for each activity it is taking, based upon that you can trim you process example …If you are dealing with a lot of records in Datatable and do manipulations, then you can use Filter Datatable, LinQ functions to cut down the time

Hope this may help you


1 Like

Hi Bro.

I have deleted all activities in my project and kept only 2 for each row activities as below picture.

I ran source code on local machine and finished in 30s, but publish into the Orchestrator and ran about 8 Mins.

I really dont understood this issue.


I am dealing with the same issue, my processes run slower in orchestrator and this affects my UiPath app.

@Mr.H did you manage to solve this issue?

1 Like

Hi Bro.

I don’t remerber.

Pls try to delete all of project’s package versions and re-publish into the orches.