Orchestrator Upgrade "A

Hello everyone

  • I tried to upgrade our orchestrator from 2019.10.18 to 2020.4.
  • Setup is Single-Node
  • Separate SQL Server
  • No insight and no testing installed, just orchestrator
  • Installed with PlatformInstaller, Ugrade tried with PlatformInstaller

When upgrading after 50% the following error message occures: An unexpected error has occured


Last part of the logs:

[05B0:07C0][2020-05-12T18:11:38]i000: ExecuteMsiMessage: Log = 1: 2 2: 1 
[10B0:0610][2020-05-12T18:11:38]e000: Error 0x80070643: Failed to install MSI package.
[10B0:0610][2020-05-12T18:11:38]e000: Error 0x80070643: Failed to execute MSI package.
[05B0:07C0][2020-05-12T18:11:38]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[05B0:07C0][2020-05-12T18:11:38]i000: ExecutePackageComplete: UiPathOrchestrator.msi complete.
[05B0:07C0][2020-05-12T18:11:38]i319: Applied execute package: UiPathOrchestrator.msi, result: 0x80070643, restart: None
[05B0:07C0][2020-05-12T18:11:38]e000: Error 0x80070643: Failed to execute MSI package.
[05B0:07C0][2020-05-12T18:11:38]i000: ExecutePackageBegin: UiPathOrchestrator.msi - should execute: False
[10B0:0610][2020-05-12T18:11:38]i318: Skipped rollback of package: UiPathOrchestrator.msi, action: Uninstall, already: Absent
[05B0:07C0][2020-05-12T18:11:38]i000: Progress: Install progress: 62
[05B0:07C0][2020-05-12T18:11:38]i000: ExecutePackageComplete: UiPathOrchestrator.msi complete.
[05B0:07C0][2020-05-12T18:11:38]i319: Applied rollback package: UiPathOrchestrator.msi, result: 0x0, restart: None
[10B0:0610][2020-05-12T18:11:38]i329: Removed package dependency provider: {#######}, package: UiPathOrchestrator.msi
[10B0:0610][2020-05-12T18:11:38]i351: Removing cached package: UiPathOrchestrator.msi, from path: C:\ProgramData\Package Cache\{#######}v20.4.0.0\
[05B0:07C0][2020-05-12T18:11:38]i000: ExecuteComplete: Status: -2147023293
[10B0:0610][2020-05-12T18:11:38]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{********}, resume: None, restart: None, disable resume: No
[10B0:0610][2020-05-12T18:11:38]i330: Removed bundle dependency provider: {********}
[10B0:0610][2020-05-12T18:11:38]i352: Removing cached bundle: {********}, from path: C:\ProgramData\Package Cache\{********}\
[10B0:0610][2020-05-12T18:11:38]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{********}, resume: None, restart initiated: No, disable resume: No
[05B0:07C0][2020-05-12T18:11:38]i000: ApplyComplete - Status: -2147023293; Result: None

Any Ideas on how the upgrade the orchestrator?

PS: It would also be possible to uninstall the current installation. Will uninstalling the orchestrator delete the sql database?

1 Like

Hi @noah.studach
Welcome to the UiPath community

Some of .msi files can be moved to quarantine by your virus guard.
and also Some of ports on your servers are blocked by your organization policy or firewall
Please check with both with your windows admin
and also check where your .Net framework (update with new one if not)

Thank you.

I have .Net 4.8, so that should not be the problem. Also the prerequisites are almost identiacal (2019.10 vs 2020.4)

My virus guard shows no activity.

I do not see how blocking ports impacts the installation. The current setup was able to install 2019.10 so that should not be the issue

basically mention error code comes around what i had mentions , anyway
check whether just run your MSI in general pc or some ware , (dont install it , just go through some steps) if its ok then hope your security controls are not blocking

if not i hope that contacting technical support is best

I did run the powershell script for the Server Roles and Features, but the error persists.

I ran the .msi installer and it throws no error until it notes, that there is already a Orchestrator Instance installed.

Hello Noah,
we have run into the same Problem. Where you able to solve it?


Not yet.
It seems that the initial installation was corrupt and therefore the update fails

1 Like