Orchestrator Install error

While installing Orchestrator, UiPath Platform Installer throws “An unexpected error has occurred”.

The above error is thrown when it is at “Searching for related applications”. So far could not find more logs about this install error. Apparently there is an MSI installer for this product, which has cli flags that could throw more light on it, but so far I have not been able to find how to get hold of the msi installer.

Here is some information about our environment:

Windows Server 2016 on VMWare with:

  • .NET 4.7.2
  • IIS 10.0.14393.0
  • IIS URL rewrite module 2
  • Microsoft Web Deploy 3.5
  • PowerShell Version 5 (Execution policy set to RemoteSigned)

SQLServer 2013 is a separate server.

Any help on how to move forward would be highly appreciated.

Thx

I tried installing .NET 4.8 with no luck.

btw, UiPath Orchestrator version we are trying to install is v2019.10.14

Was there a solution for this ? I am having the same issue

Not yet. I hope someone from UiPath would chime in and get us access to msi installer so that we can create installation logs that would show why it is failing.

The msi installer reaches to only 19.4.4 not 19.10

Same error here. :grimacing:

Resolved after downloading and running the posh script.

2 Likes

Had the same issue,event logs didn’t log the issue either.

This problem may be caused by broken install file.

There is an error message in the “Bundle_2019 ~ .log” file under the "C:\Users<users>\AppData\Local\Temp " directory.

Please download and install the new installation file.

1 Like

Reach out to Technical Support - They will provide the MSI link, if you already have an EXE URL, often it is just adjusting the extension of the file. If you need a specific version or build support can provide that or look at the Enterprise Edition links provided in the Resource Centre of cloud.uipath.com and modify accordingly.

there is a 19.10.14 UiPath Orchestrato MSI package that was made available with the LTS.

I haven’t used the full platform installer (exe or msi), generally use the specific MSI for Orchestrator and Studio (Robot/Studio) as we automate the installation and image creation.

Once you have that you can use the /l flag to set your log path and see what is erroring. As @Benoni aluded to, make sure that you have all your prerequisites installed.

One thing to point out is the prerequisites pages points to URL Rewrite 2.0 published in 2015, there is a newer one 2.1 released in 2017

Thx Benoni. Manual execution of “InstallRolesAndFeatures.ps1” did the trick.

Thanks a ton.

You’re welcome. :+1:

Thx Tobeware. after check broken install file.because not set up program on IIS.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.