Open workbook activity


#1

Hello everyone.
I doesn’t have the “open workbook” activity through I have the “close workbook” activity.
Excel package is install. I’d try to uninstall and reinstall, still not show up.
I use an trial version of uipath version 2016.2.6274.
How can I fix this problem?


#2

Hey @alice

In previous some versions it was there but can you tell me the use case for this activity here for you?

If you wanna read data of a workbook you can use “Read Range” Activity from Workbook Activities. It will read from the specified workbook and will return output in datatable.

Regards,!!
Aksh


#3

Hey @aksh1yadav,
Thanks for the quick reply!
I need to read columns in workbook, compare with others variables contains in my uipath, write new cells in the workbook and save it.
As far I understand I was thinking “open workbook” will be the best.
I am not sure that this activity has disappear in that version, because I have the “close workbook” one. Maybe I have problem with configuration?


#4

@alice

Everyone have their own logic so same things can be done without open worbook by workbook activities. Even you can use excel application scope as well but if you wants to use “Open Application” activity then cehck below screenshot and let me know if still it is not there for you.

Regards…!!
Aksh


#5

@aksh1yadav : ok, this could be a little tricky for a newbie like me! :wink:
concerning the open workbook activity:


My problem is I can’t find this activity, even by search it.
Regard,
Alice.


#6

as i said this was available earlier so will be available in the compatibility pack to support previous versions for backward compatibility.

Just install the below package

Regards…!!
Aksh


Open an excel file with Open workbook
#7

I check that I installed all the available packages and I still not have the activity. (I have the auto update checkbox ok)
Regards,
Alice


#8

If I well understand the answer of technical support, the “open workbook” activity exist no longer. So, I must move to “excel application scope”.


#9

As i mentioned earlier

:innocent::innocent::innocent::innocent: