Nothing exists, what am I doing wrong?

I have tried all 3 “exists activities” {Image, Element, Text} , and they never* find what I point them at. I’ve been messing around with this for months. Why don’t they work???

Selectors validate and highlight.

Selectors validate and highlight in UI explorer.

Having this problem in IE 11 and Firefox. Working on the advanced course, lesson 2.

*There was a period last week where one of them worked, but then just as inexplicably, it stopped working.

what are you trying to catch?
@Robot.Builder.9001

I’m not trying to catch anything. Currently, I’m looking for the error message below.

I’m not sure why, but UI Explorer doesn’t save the selector I make, and I have to reconfigure it every time I launch it. This validated before I tested my file, and had stuff in the white spaces.

Current:

After I just reconfigured it:

And here you can see the selector appears to work:

But I have to modify it a little bit

But you can see that it still validates

the first time you run it, the workflow works?

Nah bruh, idk how else to say it: it doesn’t work.

Hi @Robot.Builder.9001

In When xaml file you are getting selector error?
Also match this path.

image

I’m not sure what you’re trying to say.

This (screenshot below) is how things wind up when they fail.

1 is the problem, because it does not evaluate properly. No matter what I try, it never evaluates to “true”.

2 is the red herring because UIPath skips over the test condition and then fails. This is NOT where I need help.

The path you are giving on Navigate. Is it open on browser?

Yes, that’s why I resized the browser window to fit in with the other data points.