UiExplorer can't find self-generated selector

selector
activities
studio
uiexplorer

#1

I’m using a local application and I wanted to explore the selectors. I launched the UiExplorer tool and indicated a button and it generated the selector. The ‘funny’ thing goes next. When I press ‘Validate’ selector, without any changes in the selector, it shows that it can’t find the UI object. The UiExplorer cannot find the selector the UiExplorer generated! How is it possible? Anyone faced it? Let me please know if you have any suggestion to troubleshoot it.

Hence, I can’t use the Click and the others activity with this selector.


#2

Hi @MGMKLML

I remember this happening to me in Chrome. I blamed the Chrome extension back then, as it was not working properly. Internet Explorer solved the issue for me.

However, you are using a local application. Maybe there is some compatibility issue. The only thing I can think of for you to try is these two options in Ui Explorer:
image


#3

Yeah it’s not a browser unfortunately (or fortunately) and I tried all the three methods and the only one who managed to identify the button, not a few button simultaneously, was the UI Automation. So the rest two are simply useless in my case. But when it identifies the button and generates the selector it says it failed to find the corresponding UI Element when validating it. It even highlights the button when in the process of generating the selector but then it just can’t find it :frowning: I can’t seem to find ways to avoid it. I tried to use tabs to get to the button but it also fails from time to time. The last way is to use Click Image but it’s also an unstable way unfortunately.


#4

@MGMKLML Does the selector stay exactly the same in UI Explorer, also if you get it once and then get it again a few minutes later? I’ve seen certain elements of selectors change (seemingly random) even in a short period of time, so this might be the case. If it is, you can try and remove that part of the selector to see if that does work.


#5

Indeed, but shouldn’t it normally be solved by using the “Attach to live element” function?

That is another suggestion to try @MGMKLML


#6

@loginerror, @evangemert, No this isn’t the case unfortunately. The selector is clearly static whenever I check it.