Not able to run shared App

Hi,

I have developed an UiPath App (which uses start process activity) and shared it with multiple users with Run Only permission. Whenever user runs this app he gets below attached error. Please let me know the steps to fix this error.

Capture

Hi @poorna_nayak07 - Is the process attended or unattended?

If it is attended, have you shared it with those users and their robots? so that it is available in their Robot Tray/Assistant.

If it is unattended, do those user have permission to invoke the process?

Hey @ankit.saraf,
I have unattended processes and assigned folder administrator role to the user

@poorna_nayak07 can you share the app with us?

1 Like

Yes @Prashant_Verma

is this solved? I have the same issues

No this issue is not solved

1 Like

I also have a similar issue - I have added a user at the org-level, added them to the Automation Users group and shared the app with them, but they are unable to trigger any unattended processes. The error that is displayed simply says ‘OK’ and I can’t see any logs to identify where the issue lies.

EDIT: Same issue as How to rectify process error in UiPath Apps - #5, but the marked solution there is not valid.

It seems users must be given permission at org, tenant, folder, and app level in order to run unattended processes within an app. Automation User and Allow to be Automation User roles are required.