Not able to access Type Argument for For Each Loop

In current version (2023.4.0) of Studio I am not able to change the type argument of my collections. Please help.

1 Like

can you check and maybe upgrade UiPath.System.Activites to the newest version (maybe try also alpha, set for this activity filter)


I am using the latest version of UiPath.system.activities package and also the Include Prerelease filter is checked in my project. Still not getting option for Type Argument property in For Each

can you share screenshot from

  • Project panel / references the top part like:


  • activity card
  • property panel



Can you try to downgrade System.Activities package to the latest stable 22.10.4?

Select System.Activities package
Change version to 22.10.4
Click Update
Click Save



Yes, this option is available in downgraded version. But that is a temporary fix. I am looking for a solution in the current version of the Studio.

Thank. Your comment helped me


Thanks. I don’t know why they removed the option to specify the type of the variable. I was getting all kinds of errors because I was unable to specify the type.

Convert currentItem to the prefered typeargument within the For each. Then refer to the new converted variable when using activities within the For each

1 Like

Thanks for the info but, the point is that there should be not need to cast the value.
That’s why specifying the value beforehand in the foreach activity was for.
I still don’t understand why they removed it.

Thansk @Len1 this worked for me!

But totally agree with @Axel_Albert that this should be in the properties pannel.