No robot available for use

There are security issues.

When running from Studio you access queues, assets depending on the username/robot you’re using accessing the server. Therefore a login in required.

Now, if you have a process that runs locally just disconnect from the Orchestrator.

Neverending security vs convenience… :slight_smile:

In the UserGuide currently there is this paragraph:
Note: If you register Studio as a Robot to Orchestrator, but do not provide the correct credentials in the Username and Password fields, you cannot run workflows.

Could it be made clearer there that when connected, only registered usernames are able to run any workflow (from Studio included)? As it stands now it’s easy to read it as a trivial user error warning (wrong creds → won’t start, very likely to not see a change there at all compared to previous versions).

While this change has it’s merit, it would be nice that these kind of changes would be more visible in the documentation, as it can impact maintenance/debug processes - not high impact, but a little panic moment can definitely ensue :wink:

2 Likes

Uninstall Uipath Studio and re-install, this will fix the issue.
Possiblly ‘C:\Users\vijpaul\AppData\Local\UiPath\UiStudio.settings’ has issues or is missing.

Regards

Yeh I think it is to do with credentials because my robot was provisioned as usual but I had this error. I then reset the settings in system tray and it worked fine. I agree with Andrzej that this could be clearer - e.g. Robot config in Orchestrator is incorrect due to wrong credentials, this would also help debug in Orchestrator as you would know that the credentials are incorrect as opposed to something else.

The good news is that I searched the forum and found an answer straight away! :smiley:

1 Like

Hi badita,

how ii can install C:\Users\user\AppData\Local\UiPath\UiStudio.settings

Hello,

I have similar issue now. On a single machine with one , I have installed UiPath, but when i log in with another account and try to access UiPath, it says “No Robot available to use for user”. I just want to run those robots via studio as of now locally. Can someone please help me, how to fix this? I dont have access to the link mentioned above. i.e.

Hello, I am also facing the same issue… After reading some posts here … C:\ProgramData\UiPath this is the location of my application. Should it be uninstalled ?? @badita as your comment read (Please check that the file C:\Users\user\AppData\Local\UiPath\UiStudio.settings exists and/or
or reinstall Studio.)

@qateam @richarddenton do you have any steps on how is this repro and what is the workaround?

I am currently using the trial version of Uipath studio and testing the app for automating our companies internal process. Our IT team has opened the port for me so that i can schedule the job using orchestrator, In the dashboard or in the robots menu the my machine/robot is shown as available, but when i run the job i am getting this error " Unable to Connect to remote server".
The Uipath service is running, Is this because i would require access to any ip or is there any access to be given from Uipath team ?? Please can you help me out.

https://forum.uipath.com/t/no-robot-available-for-use/2297/3

Hello,

Regarding the message “No Robot available to use for user” . This is not an error, is the intended behavior, and happens when there are multiple users defined on a machine, the machine is connected to orchestrator, but in orchestrator you don’t have a robot defined for each user. Execution will work only for the users that are defined in orchestrator. In the future the message will be more clear.
To avoid this you have following options:

  1. Add a robot for each user in Orchestrator
  2. Disconnect from orchestrator.

Let me know if this helps,
Thanks

4 Likes

I was checking the Forum for this issue and Cosmin’s posting helped me resolving the issue. Thanks Cosmin

@badita @cosmin.sandulescu this problem is still pretty hard to debug.

image

Couple of points:

  1. If the username and password combo is not correct I don’t think you should be able to initially provision the robot
  2. Can we get more helpful error messages rather than this robot is not defined - when it clearly is.
  3. More info about the correct domain name to use would be helpful (perhaps in Studio or the system tray panel)

Reading Cosmin’s comments it seems Orchestrator thinks there are multiple users but that’s not the case. I am the only user on my machine. I’m wondering whether it’s related to having previously registered using the trial version rather than CE.

Hoping to resolve this in the morning so I’ll provide an update.

My colleague @alp.uguray is also encountering this now. We think it’s something to do with the way UiPath is or has previously registered against the Administrator account of the machine.

I just did a full uninstall of CE including local, roaming and program data and still getting the error. I have never logged on to this machine as an Administrator (I am local admin).

Thank you Richard. I am struggling with the same issue right now. I was checking the logs and it seems to be an error caused by not recognizing the UiRobot at all:
12:35:33.2848 Error {“message”:“[State Machine Top Level Error ] Orchestrator information is not available. Please check if UiPath Robot Service is started.”

My understanding is that my account domain\ALP.UGURAY is not connected because the administrator account in the laptop X-US-1 is connected. I suspect that It may be an issue based on the account privileges on the laptop itself or the way UiRobot is set up between accounts.

Hey,

When i am trying to run the jobs manually through the orchestrator, it shows no robots available. What could be done to resolve this.Please help somebody.

Probably forgot to add your Robots to Environment.

Umm no…My robot is probably connected to the environment. I have re-checked it.
Could there be some other reason???

@badita @richarddenton any guesses on this?

In Orchestrator go to Robots section and make sure your robot is in Available status.
Then in the same section switch to Environments view, open your environment and make sure your robot is added to it.

If you’re unsure on the steps, check orchestrator.uipath.com and/or Orchestrator training in the Academy.

If all above is fulfilled and still not working, please add screenshots of those (hide confidential things if needed).