New .xaml Files Not Appearing in Library

I have a library of code that I inherited from a previous developer. I attempted to add a newly created .xaml file to the library folder, republished and updated the packages in the main Studio project, but the new .xaml file does not appear. Below is the library folder and the missing .xaml in Studio.

Would it potentially be because I created a whole new project and then moved the .xaml file into this library folder? I was unsure how to create a singular .xaml file in this existing folder and not make a full project. Does anybody know how I would create a single .xaml file inside this library folder?


Did you upgrade the dependency in the other projects that use this library? Simply publishing the new library version isn’t enough, you have to then open all the projects that use it and upgrade them.

Also, copying a file into the library is fine as long as you have the necessary dependencies in the project. However, all you really needed to do is right-click in the project tab and select Add → Sequence.


Yes I updated the package inside the project but the .xaml file is still not there. The problem is this library of code (shown below) is full of .xaml files. There isn’t a main file to open where I would then add a sequence to the library. So instead I created a new project, did my work on the main.xaml file, renamed that file, and then moved it into this library folder.

You don’t need a Main.xaml - any file can be the entry point but that’s irrelevant to a library. I’m not talking about adding a sequence to an existing XAML file. Add->Sequence is how you add a XAML file. Do it and see what happens.

You don’t have to work in Main.xaml - the name of the file is meaningless.

But that doesn’t solve your main issue. If you did publish the library after adding the new XAML file, and did update projects that use the library, then something else is going on. Try right-clicking the new file in the library project and make sure you see “ignore from publish” (don’t click it) as an option. If you see “Set as publishable” instead, that means it’s not publishing the file with the project.

That has nothing to do with moving it to a library. Which file is the entry point is not stored in the XAML itself. You can take a XAML file from a process and move it to a library, it doesn’t harm anything. There’s no difference in the XAML file itself.

@postwick yes you are correct. Thanks for correcting! Removing my solution.

I know this. But what file would I UiPath file would I open and then do Add->Sequence inside of if I am creating a new .xaml for this library?

And I’m sorry, I am not sure exactly where I am supposed to be doing this. The new xaml file is not inside Studio so I can’t click it there. And right clicking it in the windows project folder does not give me that option? Thanks

You don’t add sequence inside an existing file. You don’t do it from an existing file. You right-click in the PROJECT panel and select add sequence. The terminology is confusing. Add Sequence is adding a XAML file.

Right click anywhere in the Project panel and select Add->Sequence. It adds a XAML file with a Sequence inside it. You could choose Add->Workflow and all it does it add a XAML file with a Workflow activity inside it instead of a Sequence (which you could delete anyway and do what you want).

I think one thing that may not be obvious is that when you open a project you aren’t opening a XAML. You’re opening the project.json file. You can right-click the project.json file, open in Studio (if it’s not already associated with Studio) and with no XAML file open, right-click in the Project tab and select Add->Sequence.

1 Like

You are right-clicking inside the PROJECT tab in Studio:

Ok I can try adding the .xaml file after opening up the project.json file for the library. Thanks.

In terms of the right click inside Project, I don’t see “ignore from publish” or “set as publishable”…


Right-click the actual XAML file and you’ll see either “ignore from publish” or “set as publishable”:


Also, if it’s currently set to ignore for that file, the file will be greyed out.

I appreciate all your help.

My picture was me right clicking on the XAML file and I still did not see that option. I am wondering if it is my version of Studio or the fact that I am using Windows-Legacy.

I also just created a new xaml sequence inside the library project, republished, and updated the packages again and the xaml file still does not appear.

@jpreziuso ,

Try this final one from me.


Ashok :slight_smile:

Thanks for this. I followed these exact steps except for I added a sequence and not a workflow, but I don’t think that would make a difference. I am wondering if Windows-Legacy vs Windows could be an issue.

Give it a try :genie:. That could be reason.

I’m pretty sure legacy is why you don’t see the “ignore from publish” option.

I wonder if the problem where the activity doesn’t show up is that it’s a project built on an old version of Studio vs what you’re using now.

I would definitely update to Windows. It’s our standard now, and any old automation we touch is updated. I would also update the dependencies to match your current Studio version.