My project executes perfectly in my local machine , when deploying on VM it says Document is not valid

Please see attached the pic of error list I get when im trying to deploy the same project on VM .

Kindly help.

Chcek if dependencies are installed on VM. If its possible for you, open studio on VM and look for any dependency error

Hi @automated ,

Could you let us know what was the Project Compatibility used when working in Local and was there already a workflow/project created in VM where you had added the files from Local ? If so, what was the Project compatibility of the project created in the VM.

We do see this error when opening a workflow created using Windows in a Project created using Windows-Legacy.

You could maybe confirm on this and also check if there are other incompatibilities as well within versions of packages.


I have seen this error try below options:

  1. Deleted the project.json file and install all dependency again.
  2. Delete project and paste the zip file in VM and try to open.
  3. You might need to clear cache in the VM UiPath path ( this option not sure u know path of your VM cache).


I have done all the above steps, but I got the same error msg every time.
My Project version is 2022.12 and framework is ‘Windows’ and VM enterprise version is 2020.10.
I can’t deploy because of the above limitation, how can we resolve the issue?
How to set parameters to deploy project of latest UiPath version.


Yes, the local machine version is "Windows’ and the VM enterprise licensed version is different it’s 2020.10.

How can I deploy in this case when compatibility is different?

There’s likely an issue with your dependencies or incompatibility between versions. The process you’ve developed in a v2022.10 environment may not be compatible with certain v2020.10 configurations. See points 8, 9 on the compatibility matrix here.

My guess is you might be activities or packages from 2022.10 that are not compatible with 2020.10. If that’s the case, try to align your environments as best you can to avoid issues like this. Might be easiest to downgrade your development environment to match your production VM.

Actually, the cause is that we are not supporting the forward compatibility:

  • Projects created with alpha or beta Studio versions might not be compatible with newer Studio builds, nor can they be executed by newer Robots.
  • We support backward compatibility, except for breaking changes announced in the official release notes, and following the product lifecycle.
    Newer Robots can execute projects created with older versions of Studio. For example, a project created with Studio 2018.4 should work on a 2019.10 Robot or newer.
  • We do not support forward compatibility. Projects created with newer versions of Studio might not work with older Robots. For example, a project created in Studio 2019.10 might not work with a 2018.4 Robot.

Reference: Compatibility matrix

So does it mean, the production environment VM is 2021.10, will it not allow me to deploy the project developed in version 2022.12? According to matrix it says that I can .
When I copy my project on the VM and try to open and debug the project it gives me an error ‘Document Invalid’ error prompt.
Or is it related to some licensing issues or certificate issues?

It will not allow running and maybe deploying.

So now what should be done, How can I downgrade my project to that version, I have tried changing the project.json, etc solutions. Not working.
Obviously, some activities are not recognized in the old version, and re-doing them is delaying the deployment deadline fixed.
I’m getting this error: Failed to create a ‘Version’ from the text ‘V2’.’ Line number 135’ and line position ‘316’
I also got an update notification, find the attached pic, should I proceed with the update or not?


How can I downgrade my project to that version?

You cannot downgrade the Studio project version.

Either you are upgrading the robot that should run to at least the same version of Studio that built the process, or you are re-building the project in the old Studio Robot version. (some activities may not work as the package versions will be old)

Is up to you how you want to proceed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.