Move outlook mail message - The specified folder does not exist >>> After +/- 50 mails that went good

Hi All,

I’m using a Move outlook mail message in a flow combined with the Get Oulook mail Messages activity. When I do a run the run goes good, till I’m at the 50/60th mail message. Then I get mostly a Runtime Execution error, with the message that the specific folder does not exist. Before I get this error the bot placed all several mails into the defined folder. Anybody else with the same problem?

Kind regards.

This error appears:

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.ArgumentException: The specified folder does not exist
at UiPath.Mail.Outlook.Activities.MoveOutlookMessage.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Hi @M_L

Hope you are well.

It seems like people have gotten a similar error while working with Excel workbooks (and other applications).

Not sure if this might be of help - this is what I’ve found:

Based on the above, if you add a short delay between moving the email between folders, does that still result in the same error?

Have a great one further! Keep safe.


I start now with kill process “Outlook” combined with delays for the moving mail acitivity. Now it works without any errors. :slight_smile:


1 Like

I tried the delay, but doesnt work.

I also read you should use / instead of \ - bot neither works.

It says that the specific mailfolder doesnt exist.

I checked the path a thousand times, so thats not the problem. Can you help me?

If you do the debug method, gives it then also the error that he specific mailfolder doesn’t exist?

Read should be: Inbox*** *** = Name of your folder.

I found out, that i was using the wrong activity. I used Send outlook mail message.

It works now, thanks :slight_smile:

Send outlook mail message works really well. Just a few things that we experienced was that Outlook needs to be open for a mail to be sent or received and in some instances (also activity dependent) the folder you are working from (inside of Outlook) needs to be focused on.

We generally use the Microsoft Office 365 activity instead however, it does require an active Azure subscription for the app registration.

Both come with their own “gotchas” :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.