Mouse drag issue in Adobe Acrobat Reader DC

Good day to all.

I know the automation of mouse drag issue is not new and there are multiple posts about this issue and there is also an official solution for mouse drag (How To Automate 'Drag And Drop').

I wish to go into something more specific regarding this issue. I am trying to perform the mouse drag action in Adobe Acrobat Reader DC using Studio to create a digital signature field. Unfortunately, the process keeps getting stuck upon finishing the “mouse click down” action. It does not give any error. If I move the mouse manually, it will retain the “mouse click down” action and highlight text along the way. If I further do a left click, the process will then continue towards the end.

I am thinking this issue might be specific to Adobe Acrobat Reader DC, as I have tried the same solution of automating mouse drag on something else (listed below) and they are working fine.

  1. Drag a desktop icon and place it somewhere else.
  2. Go to a random website and drag mouse along some text to highlight them.

Studio and Acrobat Reader Info:
UiPath Studio 2021.4.4 Community Edition
Adobe Acrobat Reader DC Version 2021.005.20048

Does anyone have similar issue or has anyone tried automating mouse drag in Adobe Acrobat Reader DC?

Hi @chanshaowen.keith,
Welcome to the Community!
I think that as you said it is specific to Adobe Acrobat. Maybe this document will somehow help you:

1 Like

Hi @Pablito ,
Thank you very much for the assistance. While the document provided is useful, I have forgotten to mention that I actually had no issues in identifying and selecting UI elements in Adobe Acrobat Reader DC when building the process, which the document is addressing. I am more on the thought that the “mouse click down” action got stuck upon finishing its action.

Are you able to record it somehow? We could use your case to check with our technical team if that might be a bug.