Missing uiPath Firefox extension when I start a process PiP


if I start a process using Firefox with assistant (or debug in studio) in PiP mode the firefox startet by the robot has no uiPath extention. Also I miss individual settings in that browser.

If I start a other Firefox process manually in the PiP window, Firefox seems to be fine.

Of course, the robot did not work without the extension.

Why does the robot not use “my” firefox settings?

Thanks & Regards


Hi @fabian.behr,
Welcome to the Community!
Can you check if FF opened in PiP mode is using your profile? If not then you need to make sure extension is installed for all FF profiles.

1 Like

If the robot opens the FF in PiP it is using a unkown FF profile.
If I open a FF in the PiP window, the my normal Session FF is used with my profile

1 Like

Hi @Pablito ,
I have same issue as Fabian.

Firstly I removed all other FF profiles except the default with installed UiPath extension.
This didn’t help so I created another profile and unchecked start of any profile automatically in hope to raise window with profile selection but this didn’t work either because it never asked when process is running.

In PIP mode it simply runs FF in unknown/temp profile which is not visible in FF about:profiles.

Used soft:
StudioX 2020.10.4
FF 78.7.1 ESR (64bit)


1 Like

I have such issue for my firefox when opening in PIP, is it any updates on this?

Still have the problem. I try to use IE, thats works. But I need the Firefox…

1 Like

Hello, I had the same issue and i found that the profil opened on pip is not the same as the one on the Firefox.

You have to copy your default browser profile (dont copy storage it contain ur temporary files etc) (type about:profiles on firefox to find the folder) To the one that are used when Pip open Firefox : (type in the file explorer : %localappdata%\uipath\Pip Browser Profiles )
It worked for me

1 Like

Hola, me interesa mucho como lo resolviste puedes ayudarme con un poco de mas información por favor-
quedo atento

Hi. Installing the Firefox extension by policy should help Extension for Firefox


Hello, the extension does work for me, but when you try to do it in pip in image picture in picture the extension does not work for me

Try the following: in the Properties tab for Use Application/Browser (assuming that’s how you open the browser in PIP) select User data folder mode: DefaultFolder.

This will open the browser with the same user profile as when you open it manually. There is one disadvantage: you cannot open Firefox in PIP and the main session at the same time.


Thanks a lot!! this really solved my problem :slightly_smiling_face: