UIPath Chrome Extension not installed in PIP


unfortunately for whatever reason, the UIPath Chrome Extension wasn’t installed ‘everywhere’. It works when Chrome is automated without PIP, but within Picture-in-Picture, Chrome has no extensions.

This only happens on some machines seemingly at random.

We cannot use the default profile since it’s in use by the user.

I don’t really understand why it works on some machines and doesn’t on others.
Are there any tricks or workarounds to fix this?


1 Like

Hi @T0Bi ,

If you have installed Chrome extension on your machine, you should be able to enable it for the first time when Browser opens up in PIP window when PIP is launched the very first time.

I wrote a utility to help our users do this.

The automation starts in PIP and opens up a Browser. It then pauses with a Message Box asking the user to check for, and enable the Extension.

The user enables the extension on the Browser in the PIP Window and hits the OK button on the message box.

This is repeated for each dominant Browser, in our case Chrome and Edge.

(In addition, we do other PIP start up tests such as opening other Windows applications to make sure they work)

This approach has worked for us so far. Here is a visual:


This is a great idea, unfortunately we don’t get a popup or anything. If I go into the pip browsers extensions there is not a single one.

This only happens on selected PCs and we cannot figure out why.

Hi @T0Bi

Let me explain a bit how the whole thing works. Might not solve the problem, but at least you will understand the underlying details and that might generate some ideas:

There are three main ways of installing the Chrome exception:

  • per user and per system (for all system users) - both require manual extension enablement in the browser
  • per policy - which enables it automatically and transparent. But the extension has to be whitelisted.

Regarding Chrome and PIP: there is a limitation Chrome currently has which manifests as follows:

  • if you’re running a Chrome instance in the main session, it cannot run in parallel in the PIP session (child Windows session) with the same **UserDataProfileFolder ** as Chrome puts a lock on that folder. The default UserDataProfileFolder contains all the information for any of the Chrome profiles you might have defined on that machine (valid for both main and PIP sessions).
  • to be able to launch Chrome in PIP when you already have a running Chrome in your main session, you need to start it with another UserDataProfileFolder, other than the default one. We have added an option at the UseApplicationCard level that can be used to automatically do that for you. Check the explanation of the UserDataProfileMode and UserDataProfilePath properties, here.
    You can even configure the extension and browser at design time, by setting the above properties as you wish and launching the browser just to enable the extension, with the small button near the ApplicationPath input field (right side), exactly the same way it will be launched in PIP.

Now, back to the extensions: if you have installed it per user, that will apply to any Chrome profile under that user, no matter the UserDataProfileFolder it uses. And needs to be enabled manually, before executing, as explained above.

If you still don’t see the prompt, then please provide the following information so we investigate further:

  • Studio & UIAutomation version
  • Chrome extension ID and how was installed

Best regards,


The pop up was created by an automation that runs in PIP.
Did you try to Open UiPath Studio in PiP and install the extension from the Tools menu?
If something doesn’t open in PiP using the Start menu, use the Windows run prompt to browse to the Studio and open it that way.

The other option is the direct URL to the extension below. I just confirmed that I can navigate to this URL inside of the PIP Window


Yes, this didn’t work unfortunately.

That’s a fantastic idea, I’ll try it. Thanks a lot!

Thanks for your explanation, now I think I kind of understand the problem.

I’ll post again once I found a solution!