Maximize window not working from Orchestrator

This issue is regarding maximizing the Internet Explorer window when running from Orchestrator.
Before going in to the issue, I would like to mention that I have gone through some posts in the forum and tried all those but nothing worked for me.

When trying to maximize the Internet Explorer window, “Maximize Window” is not actually maximizing the window, the application window is confined to only some part of the screen but not the complete screen.
I used a “Take Screenshot” activity and found out that, when ran from Orchestrator, the maximize operation is actually getting triggered, but not doing its job. I could definitely say the maximize was not happening because in the screenshot, I could see the “Restore” button on the top right, which would appear only if the window was maximized.
This is happening when the robot is left to run unattended. After triggering from Orchestrator, I opened the machine in which the robot was actually running and I could see that, the moment I opened, the application window is spread on to the complete screen. So when left unattended, the application window (internet explorer) is being confined only to a small part of the screen. The “Maximize” does not error out, but it is not exactly doing what it is supposed to do. I also tried “Send Hotkey”, as mentioned in the UiPath Forum, but that also didn’t work. I tried using these activities inside an “Attach Window”/“Attach Browser”, but these also were of no use.
This is not being faced when the robot is run manually.
Also tried changing the resolution in Orchestrator, this too didn’t help.

This is causing a major hindrance to the further operations as there are many “Click Images” in the code. The web application doesn’t support any other activity so “Click Image” is the only option we are left with. Now that this maximize is not working, these clicks are failing and I’m not able to find an alternative for these clicks, so maximize is the only option for these clicks to happen. I’m afraid I cannot attach the screenshot as it contains sensitive information. Please help!

Thanks.

Hi.

This can be tricky to solve without actually seeing the application or screenshots of what the screen looks like after it maximizes in unattended.

I can say from experience that some applications require that the window is a certain size before it is opened, which becomes challenging sometimes as unattended. The best solution to this would be to ensure the robot is running at correct resolution; the screenshot would also prove that the resolution is correct.

I think I helped my associate set up a Ctrl+Space hotkey (specific to that application) sequence to get a tricky application to maximize, but I don’t know if your application is similar.

So anyway, you are probably going to need someone to actually see what is going on to try and solve this. If you can’t provide some images or anything else that can show what it is doing, then I would recommend using Tech Support

Regards.

1 Like

Hi @HimajaAk ! You may have resolved this since it’s been a few months, but in case you haven’t, I have found an uncomplicated and (so far) reliable way of maximizing my IE windows: Send Hotkey Activity, using Windows key and up arrow. This also does not cause issues if the window is already maximized. Hopefully this works for you - it was not a solution I came across in the forums while doing my own search for a resolution.
Sorry, I do not have any idea why this happens on your unattended bot, but not the attended bot. If you discovered the answer to that, I would be curious to know what was causing it.

Thanks!
Meagan

Capture

5 Likes