Firefox browser is not maximized while run from orchestrator whereas it is fine in studio and assistant

Hello everyone,

I am facing an issue running the bot from orchestrator. Firefox browser is opening but it is not maximising when the bot is run from orchestrator. I am using use application/browser activity to call firefox. It is maximising when I run the code from studio and assistant but it’s not happening with orchestrator. Can someone please help on this ???

@sujithkr , Welcome you to uipath community,
Kindly use “Maximise activity” to maximise your window
Place this activity within open browser activity


If you need full winodow, then use send hot key and select F11

I tried maximize window, it is working fine when run from studio and assistant but from orchestrator it is not working

@sujithkr , Did you palced it in open browser actvity.
Also try

Hi @sujithkr

After modification have you publish the latest package in the Orchestrator?

What is the version of the Orchestrator?


It is 2022.4.3

Used use browser and maximize window in its property and also placed maximize window but it is not maximising when run from orchestrator else whereas it is maximising when run from studio or assistant.

Try to Switch the project to Modern Experience and use the Chromium API in Input Mode.

Reference: Input Methods

Check the unattended robot resolution to match the robot machine resolution:

Check if the robot machine scale is set to 100%.

Check if the Firefox browser is updated to the latest version

Try to remove and reinstall the Firefox Browser extension.

Reference: Extension for Firefox

Also, you may take a look here: Automation Works in Attended Mode but Not in Unattended Mode