Making web API call, Method not found

Hi ,

I am trying to make an API call. But it is giving me the below error. Can anyone tell me why am I getting this error

It seems that you have some dependencies in your project that are creating a conflict with the RestSharp dependency.

You may try also to downgrade UiPath.Webapi.activities to 1.9.3 and retry.


If you are having UiPath.Testing.Activities you may try to remove from your project and then retry.

Share your findings with us.


I tried by downgrading it with 1.9.3 version. But, no luck.

I don’t have testing activites dependecies in current process.


Can you test with the below dependencies? Which are the results?

Can you show us a successful POST request in Postman for exactly the same example as in UiPath Studio?

Show us also how you configured the Request Builder in the HTTP Request Wizard.

Which is your UiPath Studio version in the machine? Are you having multiple versions of the UiPath Studio/UiPath platform installed on the same machine?

I was able to make the call successfully in postman.

But, I am not sure how to write the body in HTTP Request activity as it is expecting string format. Can you help me on that>…

I need to execute below body value in that activity. Not sure how to write the same in Uipath. I tried passed the same values as parameters but no luck


“endToEndId”: “12345”,

“businessOrFirstName”: “Health”,

“consumerAcctNum”: “02123456”,

“consumerRoutingNum”: “135667”


If you have a C# project, your Body request should look like this:

" + "\n" +
" + "\n" +
" + "\n" +
" + "\n" +
" + "\n" +

Body Format: application/json

If you have a VB project, your Body request should look like this:

"{""endToEndId"": ""12345"",""businessOrFirstName"": ""Health"",""consumerAcctNum"": ""02123456",""consumerRoutingNum"": ""135667""}"

Body Format: application/json

Let us know if this helped you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.