HTTP Request Wizard Error - Method not found for a UiPath.WebAPI.Activities[1.11.1] package

Hi Forum,

I am using HTTP Request API to retrieve the response from the webpage. I was able to do get the information and manipulate it. Last two days back I have updated all packages and now it seems like I am getting errors.
When I update it to 11.1.0 or versions of 1.11 I or 1.11.0 am getting this error while previewing it :

But if I degrade it and use 1.7 I am able to preview and see the response in the Response tab but unable to retrieve the response as a output . The output seems to come as empty.

I would like to know if anyone else has faced this issue.If yes would like to know the resolution applied for the same.


Try to remove the UiPath.Testing.Activities from your project and let us know if worked.

I do not have this package installed in this project

Are you having a Studio 22.4 or higher?

I am using 21.10.4

It will not work.

In your case, use a lower version of UiPath.WebAPI.Activities package that is compatible with your Studio version.

Let us know if the provided information is clear.

Hi @Shreeja

Welcome to UiPath community

Have you imported the RestSharp to the “Imports” panel after installing RestSharp dependence

Try with this version 106.10.1 for RestSharp dependence


Ah …I have missed on reading this “22 or higher” so it’s obvious that 1.11.1 wouldnt work for my studio …Thank you for taking my attention on the same .

Yes I did import this but it seems like not working

Thanks for the update. Please mark as a solution the correct post in this thread in order to help other users that are facing the same issue.

With help of @marian.platonov and some hit and trial methods here is the answer to my question:

  1. If using webAPI of version 1.11.1 you should use Studio of 22 or higher otherwise you will be getting errors.
    2.I have degraded it to 1.6 this time and it worked for me. The preview panel works.
    Note : Sometime it needs headers like and “reference identifer” along with “Auth”(mandate) according to your backend structure"


Thank you already did that :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.